cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Beginner
310 Views
Message 1 of 15

Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

Hi,

 

I have tried setting the port 80 forwarding with everything by default ie Firewall (default) UPnP on (both)

But it wasn't working, I even tried restarting the router.

I have now turn off the UPnP (both) and the firewall is disabled too.

I then tried resetting the router to factory  settings, and configure the port 80 forwarding again.

 


I have narrowed down the issue to the router:

  • If I access the local IP of the server I am forwarding to if get expected result
  • from out of my network when I hit my public IP on any other port other than 80 the forwarding works no issue
  • I have tried a port checker on my public IP port 80 and it shows closed


Is there any logs on the modem/router I can check to be able to narrow down the issue?
is there any alternative modem/router I can use?
I have noticed I cannot configure the modem on bridge mode so I don't know how I could setup a 3rd party router. Is there thirst party router/modems?
any modems compatible with OpenWrt/dd-wrt?

Thanks,
\M

0 Ratings
Reply
14 REPLIES 14
Distinguished Sage
Distinguished Sage
305 Views
Message 2 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

I have no problem port forwarding port 80 on a smart hub 2.

Disable UPnP

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
301 Views
Message 3 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

Is the web server actually running on the address you have forwarded port 80 to?

0 Ratings
Reply
Beginner
292 Views
Message 4 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

The address I am forwarding to from the router inwards (from the internet) is a proxy.

So no. The "web server" I am actually forwarding 80 from the router is not on the address forwarded too from the router.

I don't think it really matters (is not the issue) I have been tailing the logs on the proxy and if the request are from the internal network (using internal IP) I get new entries in the access.log if they are from outside my local network (the internet) nothing popping in the logs.

The proxy is nginx the "final" web application is java/tomcat.

I have a feeling this has worked in the past for me with this model of router or maybe older version. I just had it replaced few months ago and its not working for me.

Thanks,

\M

 

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
284 Views
Message 5 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

The port won't be open unless there is an application running on the address forwarded to

0 Ratings
Reply
Beginner
278 Views
Message 6 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

There is an application. There is two in fact.

proxy listen on port 80 and proxies to address port 8080 where the final application is.

the proxy works perfectly fine in my internal network.

the problem is the request are not reaching it.

 

I just replaced the proxy for a static page, same result, port is not open because modem/router is blocking it.

 

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
269 Views
Message 7 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

No idea what you are doing, I don't have the same problem. Obviously not a generic problem.

There is no need to disable the firewall btw

0 Ratings
Reply
Beginner
254 Views
Message 8 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

I have tried with FW enabled and disabled.

I don't think it is a generic issue I do think however that this router are not very good with this I recall having to restart my router once to get this running, I am quite sure it was the same model.

 

Is there anyway to get terminal access to the routers?
Can anyone from BT advise how to get this working in a consistent manner?

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
247 Views
Message 9 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

There is no way to get terminal access to the hub.

In answer to your other question, you can use any third party router you like. You just need to configure the PPPoE username as the generic bthomehub@btbroadband.com and password as BT

0 Ratings
Reply
Beginner
215 Views
Message 10 of 15

Re: Smart Hub 2 forwarding port 80 with Firewall disable and UPnP OFF port not open

Just to make sure I understand.

Use the Smart Hub 2 as the modem, then connect a router to one of the network ports of the Smart Hub 2 and to the WAN port of the router and configure the router as a PPPoE client?

Or something around those line?

Sorry never done this before.

Thanks,

\M

0 Ratings
Reply