cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Hazcrew
Aspiring Contributor
601 Views
Message 1 of 8

Why is DHCP LAN IP allocation showing Static

I Have a Smart Homehub and 2 devices.

In the hub shows address assignment as 'static' even though both device gets their IP address from the homehub DHCP server.

The 'Always use this IP address: ' is set to 'no and cannot be changed.
The IP address can be manually changed

For the  Raspberry PI the name is set to the IP address not the hostname and cannot be changed.
However, the Tado central heating bridge the name is correctly set to the Hostname.

All other devices on the LAN seem to be ok some with 'Always use this IP address: ' on and some with it off.

It clearly an issue with the homehub software

I have turned off the offending devices and removed entry and rebooted router but just comes back the same when the device is turned on.

Anybody come across this or know how to remedy it.

 

Tags (3)
7 REPLIES 7
licquorice
Distinguished Sage
Distinguished Sage
598 Views
Message 2 of 8

Re: Why is DHCP LAN IP allocation showing Static

The SH2 network map is about as useful as a chocolate teapot.

0 Ratings
Reply
Hazcrew
Aspiring Contributor
590 Views
Message 3 of 8

Re: Why is DHCP LAN IP allocation showing Static

This on the Smart Hub not Smart Hub 2.

 

0 Ratings
Reply
imjolly
Distinguished Sage
Distinguished Sage
588 Views
Message 4 of 8

Re: Why is DHCP LAN IP allocation showing Static

apart from being able to split networks on hh6/SH they are the same



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
Hazcrew
Aspiring Contributor
582 Views
Message 5 of 8

Re: Why is DHCP LAN IP allocation showing Static

The problem I've got is the scripts I use are dependant on the hostname which no longer works for that device

A last resort is a factory reset.

 

 

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
558 Views
Message 6 of 8

Re: Why is DHCP LAN IP allocation showing Static

What script are you using that relies on the hostname being displayed correctly in the hub manager?

0 Ratings
Reply
Hazcrew
Aspiring Contributor
539 Views
Message 7 of 8

Re: Why is DHCP LAN IP allocation showing Static

I have have a central home automation hub which gets info from various devices, Security cameras, heating system, multimedia server etc.   scripts are used to get data from individual systems.  Its more convenient to use hostname rather than  IP addresses
Even the simple job such as SSH is easier.  Then do not have to bother about ip address changing or conflicts.

FYI a factory reset of the hub fixed the issue with the Raspberry Pi,  but it unfortunately the 2 other peripheral devices are no doing the same thing.

Final try    Factory reset hub with all LAN connections removed.

This seemed to do the trick, everything back to normal

Hazcrew
Aspiring Contributor
446 Views
Message 8 of 8

Re: Why is DHCP LAN IP allocation showing Static

Fix was only temporary - if I change any parameter or try to force IP address it reverts to static again.

I also find it will show items which are switched off as connected, and items which are connected as disconnected.

The DHCP software  in the HH6 is appalling, I guess BT only want Vanilla users.

Have fixed it permanently,  I use a Raspbery Pi Zero as a DHCP and DNS server,  gives me the benefit  of network wide ad filtering and faster web access.

BT do not do software, their cloud service software is similarly bad.  Making the service almost unusable.

 

 

0 Ratings
Reply