cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
955 Views
Message 1 of 9

ASUS Router with BT Fiber not getting full speed

I have an ASUS RT-AX88U running ASUSWRT-Merlin 386.3_2.

I have just had BT Full Fiber 1GB installed.

Using the supplied BT hub I get 850mb/s

Using my ASUS router im getting 650mb/s.

(Both tests via ethernet connection to lap top).

Could someone advise me of settings I need to change to optimise the speed.

Currently I set WAN Connection type to PPPoE, both MTU and MRU set to 1492 (default), Enable VPN + DHCP Connection set to yes.

The ASUS router network map summary shows WAN as 1 Gbps

Any thoughts on how I can get my lost 200mb/s back?

0 Ratings
Reply
8 REPLIES 8
890 Views
Message 2 of 9

Re: ASUS Router with BT Fiber not getting full speed

Near enough exactly the same here. Just had fttp/500 installed and it’s rock solid on the BT router. 
The only downside is the BT router is so incredibly limited on features / configuration - hence the AX88 purchase. 

After taking my time flashing the AX88 with Merlin 386.3_2 and setting the router up from scratch, I’m finding I get no more than 200mb down 😔 It’s also very erratic - BT router is a constant 500, whereas the AX88 is slow to ramp up and then jumps around. 

I’ve intentionally been very light on the config side of things, additional “features” are off with the only things configured being the DHCP address scope and WiFi config. 

All tests performed via enet cat6. 

The only thing that I can see being worth trying is adjusting the MTU, although something tells me this will be pointless as the 1492 would (to me anyway) be the most appropriate size. 

0 Ratings
Reply
874 Views
Message 3 of 9

Re: ASUS Router with BT Fiber not getting full speed

I use the AX88 and two AX92U's for AiMesh nodes using the firmware supplied by ASUS and not seen any slowdowns at all. Is it possible the firmware you are using is causing the slowdowns?

0 Ratings
Reply
858 Views
Message 4 of 9

Re: ASUS Router with BT Fiber not getting full speed

@Col8 

@Tnr-mx 

I'd go along with @Checked2013 thoughts and try the standard Asus firmware to rule out the Merlin firmware being the issue.

0 Ratings
Reply
853 Views
Message 5 of 9

Re: ASUS Router with BT Fiber not getting full speed

I've tried the stock firmware and it's the same issue. 

0 Ratings
Reply
839 Views
Message 6 of 9

Re: ASUS Router with BT Fiber not getting full speed

Have you tried without VPN enabled?

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings icon. If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted solution’
0 Ratings
Reply
814 Views
Message 7 of 9

Re: ASUS Router with BT Fiber not getting full speed

Do you mean the Vpn and dchp setting at the bottom of the WAN internet settings page?

0 Ratings
Reply
801 Views
Message 8 of 9

Re: ASUS Router with BT Fiber not getting full speed

Have you tried using ping to determine to determine the correct MRU/MTU, I normally go for 1488 but that's not going to make the difference that you're experiencing 


A thank you is nice, it makes the effort worthwhile, but a kudo is better, by a country mile. (I'm no poet & boy don't I know it)
0 Ratings
Reply
800 Views
Message 9 of 9

Re: ASUS Router with BT Fiber not getting full speed

@Col8 Have you performed a speed test directly from the router yet? 
(Log in to the Router > Adaptive QOS > Internet Speed)

I've spent the morning troubleshooting this again and have just discovered that I am getting the full 500mb into the router, but only getting ridiculously erratic speeds on the LAN side. 

Any device on LAN side (wired): 

Tnrmx_0-1640267082441.png

Speed test direct from the router:

Tnrmx_1-1640267125937.png

I would say it's a bug in the Merlin firmware but I'm getting the same results on the stock Asus version. 

**EDIT: The issue only appears to be on devices that are WIRED!  Using 5Ghz WiFi I'm managing to get approx. 470 - 480mb download and the full 70mb upload. 

Any wired laptop or desktop gets a ridiculously unstable connection but this is only occurring when using the ASUS  router. If I connect up the BT Hub everything is as expected / full speed. 

All devices are showing as connected @1gb so not entirely sure why I'm encountering this bottleneck. **

Tnrmx_0-1640268590337.png

 

The mystery continues... 

 

 

0 Ratings
Reply