cancel
Showing results for 
Search instead for 
Did you mean: 
greenm
Beginner
7,531 Views
Message 1 of 8

BT Smart Hub, Infinity 2 connection issue

I have just changed my WiFi setup to the new BT SmartHub and now experiencing issues which I have not had previously.

 

My previous setup was BT Infinity 2 using the OpenReach modem linked to an Apple Airport Extreme (replacing the HomeHub 3) and also a WavLink WiFi repeater to cover the whole house. This system has been in place for a couple of years with no real problems. I switched to the SmartHub as I believed the hype that the WiFi signal would easily cover the whole house; Wrong!!. I have now purchased a BT WiFi repeater and I have problems, not in having WiFi signal capability across the house, but intermittent inability to connect to broadband. This is normally resolved by switching off WiFi on my devices (iPhone, MacBook etc) and then reconnecting. This is particularly a problem with the repeater which is compounded by the fact that my Samsung TV (which relies on it) doesn’t connect and it is not straight forward switching off & on WiFi (try putting in a 16 character password on a TV).

 

This must be a very basic issue which should be easily resolved but unfortunately my technical knowledge is insufficient to fix it; any help gratefully received; or perhaps I should just switch back to my original system and put up with 7Meg download speeds (i.e. as opposed to 36 achieved with the SmartHub)

0 Ratings
Reply
7 REPLIES 7
Distinguished Sage
Distinguished Sage
7,526 Views
Message 2 of 8

Re: BT Smart Hub, Infinity 2 connection issue

have you turned of smart setup  

 

 

 

Turn Off smart setup

 

 

 

have you split the networks   

 

 

 

i

f you go to hub manager the wireless then switch toggle to separate to separate the 2 networks

 



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
KungFuSpaghetti
Aspiring Contributor
7,490 Views
Message 3 of 8

Re: BT Smart Hub, Infinity 2 connection issue

I would bypass the smart hub entirely and use it purely as a modem with extra Ethernet ports. You already have a decent router in the airport extreme, just remember to forward all TCP and UDP traffic to it so you don't get any double NAT related issues.
0 Ratings
Reply
greenm
Beginner
7,394 Views
Message 4 of 8

Re: BT Smart Hub, Infinity 2 connection issue

I Have turned off Smart Setup and isolated the 2 networks and in fact "switched off" the 5G band. After going around all the various wireless devices (of which I have 9) and reconfiguring them all seems well. I think I now need to understand more fully how the whole set-up works to get the best out of it. I think I may still have a problem with the Bt Repeater as on my non static Apple devices I have to switch off and on wireless to get an internet connection when routed through the repeater despite having good wireless connection. It may be worth pointing out that I have been involved in the computer industry since 1968, but on Mainframe systems and although I was involved in the early days of 7 layer model the "Network layer" was always a mystery although i did a lot of work on CSMA/CD 

Many thanks for your help

0 Ratings
Reply
smf22
Recognised Expert
7,392 Views
Message 5 of 8

Re: BT Smart Hub, Infinity 2 connection issue


@KungFuSpaghetti wrote:
I would bypass the smart hub entirely and use it purely as a modem with extra Ethernet ports. You already have a decent router in the airport extreme, just remember to forward all TCP and UDP traffic to it so you don't get any double NAT related issues.

@KungFuSpaghetti Presumably you're referring to some form of bridge mode? To the best of my knowledge this is not possible on the Smart Hub.

 

Regards

0 Ratings
Reply
KungFuSpaghetti
Aspiring Contributor
7,390 Views
Message 6 of 8

Re: BT Smart Hub, Infinity 2 connection issue

I have a smart hub now, I'm going to set this up later so will post up instructions up once I work it out.
0 Ratings
Reply
KungFuSpaghetti
Aspiring Contributor
7,355 Views
Message 7 of 8

Re: BT Smart Hub, Infinity 2 connection issue

Okay, I've now setup the Smart Hub and bridged the connection with my Netgear R7000.  Was fairly straight forward. 

 

Follow the below steps and don't forget about the port forwarding, or you'll end up with dual NAT'ing which will prevent any outside access in to your network for apps like Plex etc.

 

Before you start doing any router config, plug an Ethernet cable from one of the LAN ports on the Smart Hub into the WAN port on the router you wish to take it's place as such.  In my case, port 4 on the BT Smart Hub is connected to the LAN port on my Netgear R7000.

 

On my netgear router I have gone on to the config page and set it up as follows (my netgear router IP is set to 192.168.0.1, more on that later below):

 

Internet setup:

Does your internet require a login?: Select NO

 

Internet IP Address:

Select use static IP

IP Address: 192.168.1.253 (this needs to be on the same subnet as the BT Smart hub)

Mask: 255.255.255.0

Gateway IP: 192.168.1.254 (this has to be the IP address of the BT router)

DNS Server: 192.168.1.254 (again, as per above)

 

Next is the LAN side settings.  Go into the router LAN config page.

 

LAN IP Address: 192.168.0.1 (this can be anything you want, but needs to be on a separate subnet)

Subnet Mask: 255.255.255.0

 

Check the router is setup to give out DHCP

Starting IP Address: 192.168.0.2

Ending IP Address: 192.168.0.254

 

Wireless settings on Netgear R7000 - enable the wireless radio if it's not already, setup as you wish here.

 

Settings on BT Smart Hub can now be altered now that the secondary router is setup.

On the Smart Hub you need to disable the wifi radios in the settings page (go to 192.168.1.254 on your browser, again, I'm sure you already know this!).

 

Once wifi is disabled you then need to go into the advanced settings and port forwarding.  As the other router you have is going to be doing everything, to avoid dual NAT situation you need to forward all traffic from the Smart Hub to your own router.  Select 'create a new port forwarding rule'.

 

I've set mine up as below:

Rule Name: Any/Any

To IP Address/device: 192.168.1.253 (This MUST be the address of the second router whose IP is in the same VLAN as per above)

External and internal ports have been configured as follows: Port 1 to 65535

Protocol: TCP/UDP

Click the +/add button to create the forwarding rules and it should appear in the list.  Save the config.

 

On the configuration tab next to port fowarding go in to this.

Under firewall, choose disable.

Leave UPnP on, but disable the extended security option below it.

 

Save config.

 

All done, you've now bridged the routers and are now effectively using the BT Smart Hub as a modem and a switch.  As dhcp is still ebabled on the BT router you can leave the YouView box connected via Ethernet to this, as some routers do not support IGMP proxying (the Netgear R7000 does however).

 

Now if you have any apps that use specific ports, such as Plex, you still need to setup port forwarding rules on your own router if it fails to work via UPnP.  I have setup port 32400 to forward to my server on the R7000 just because it's neater and I thought I may as well configure it while I'm in there messing!

 

Anyway, that's it in a nutshell.

 

0 Ratings
Reply
UbzyHD
Newbie
6,716 Views
Message 8 of 8

Re: BT Smart Hub, Infinity 2 connection issue

If it's not too much too ask, is it possible if you can reflect these list of instructions so it can be set up with a dd-wrt router? I have tried setting up my Smart Hub with dd-wrt router but to no avail.

0 Ratings
Reply