cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
swansea330e
Beginner
1,320 Views
Message 1 of 7

Fibre 900 issues

I've had Fibre 900 installed just over 2 weeks and have the digital voice supplied as part of the service as I transferred from another ISP.

Using fast.com and speedtest.net I'm consistently getting between 250 and 350Mbps download speeds rather than the 900 I should be getting. This is both on wired and WiFi connections. I've had an Openreach engineer out who's confirmed that the speeds into my house are approx 800 and suggested a possible fault with the router. I've had the router replaced but the speeds remain the same. The SmartHub2 is on firmware version v0.21.03.07094-BT Is there a fundamental issue with the router? I did connect a third party router and got a 750Mbps download speed. If I didn't have digital voice I'd stick with the third party router unless someone can point me in the direction of using the two together without getting double NAT issues

0 Ratings
Reply
6 REPLIES 6
SuperFlyGuy
Contributor
1,296 Views
Message 2 of 7

Re: Fibre 900 issues

My reply possibly doesn't answer your question, but we moved to Full Fibre 900 a week ago, albeit keeping our original copper line for our landline (so no digital voice, obviously). Our Smart Hub 2 is on the same firmware version as yours and on a wired connection we pretty much get between 880 and 900 Mbps down and a solid 110 Mbps up, when running a speed test.

Wireless, we get between 200 and 350 Mbps down.

If you unplug the phone completely and run a speed test, do you still see slow download speed?

 

 

0 Ratings
Reply
swansea330e
Beginner
1,288 Views
Message 3 of 7

Re: Fibre 900 issues

Thanks. I’m getting between 95 and 105 upload speed which I’m perfectly happy with. Digital Voice is BTs residential VOIP product- speed test results are unaffected whether the phone is registered to the hub or not. 

0 Ratings
Reply
SuperFlyGuy
Contributor
1,242 Views
Message 4 of 7

Re: Fibre 900 issues

I think guaranteed download speed on the "900" package is 450 Mbps, so you're well below that.  I'd suggest you contact BT or Openreach as it does sound like there's an issue.

0 Ratings
Reply
swansea330e
Beginner
1,239 Views
Message 5 of 7

Re: Fibre 900 issues

It is. BT are telling me that the speed coming into my house is approx 800 which is as it should be, but the speed out of the router even via Ethernet is as per my original post. The third party router gave me correct speeds which is why I’m asking if there’s a problem generally with this router given that this is the second router they’ve sent me. 

0 Ratings
Reply
busterboy1
Expert
1,233 Views
Message 6 of 7

Re: Fibre 900 issues

@swansea330e 

The third party router gave me correct speeds which is why I’m asking if there’s a problem generally with this router given that this is the second router they’ve sent me.

______________________________________________________________________________________________

In a word yes.

If you read various posts on this forum you will see the supplied Home Hub 2 is in-fact causing problems for lots of users.

BT made a statement a few months back saying there would be a fix by October (now) dealing with the speed issues but sadly nothing released as yet and no further news on it.

Choice of two options here.

1: Wait for the fix (if it ever happens)

2: Purchase a third party router like the Asus RT-AX88U or similar and dump the Home Hub 2 leaving you with a great 910 / 110 package you are paying for.

___________________________________________________________________________________________
Say thanks by clicking the Thumbs Up icon. Have I resolved your issue? Click "Mark As Accepted Solution"
0 Ratings
Reply
swansea330e
Beginner
1,231 Views
Message 7 of 7

Re: Fibre 900 issues

Thanks @busterboy1 I’ve got a third party router which works and gives me the speed I’m paying for but I’ve got digital voice which only works with the Smart Hub. 

0 Ratings
Reply