cancel
Showing results for 
Search instead for 
Did you mean: 
nigma
Contributor
1,334 Views
Message 1 of 20

Poor HH3 performance for 160Mbit FTTP

Hi,

 

I recently had FTTP installed and signed up to the 160mbit package with BT. However, I never got the expected performance. Running speedtest.net and the BT speed tester always yielded less than 80Mbit/s in performance. Using the BT diagnostic tool told me that my line was enabled with over 200mbit/s so was trying to figure out what the problem was.

 

This morning I did a bit of an experiment.

1. Connecting my 1Gbit/s Ethernet laptop to the 1Gbit/s port on the HH3 with no other devices connected and running speedtester.net and BT's speed tester 

2. Connecting my 1Gbit/s ethernet laptop directly to the BT OpenReach Fibre Modem and using the PPPoE login details and again running both speed testers.

 

Both tests were done at around 8:30am this moring and each was run multiple times to ensure there were no random strangeness.

 

Results :

1 :  (Download/Upload) - MBits/s

BT Speed tester : 22.15/8.95

Speedtest.net : 19.05/11.5

 

2 :  (Download/Upload) - MBits/s

BT Speed tester : 288.97/15.46

Speedtest.net : 217.97/19.39

 

As can be seen, something is significantly wrong when using the HH3.. Has anybody else seen this ?

bt2.jpg

 

bt1.jpg

2439760455.png

Tags (3)
0 Ratings
Reply
19 REPLIES 19
Distinguished Guru
1,328 Views
Message 2 of 20

Re: Poor HH3 performance for 160Mbit FTTP

Yes, it does look from your results that there is a vast difference with using the HH3, not sure if anyone else on the forum has FTTP that can do a similar test?

(If I have helped you in any way please click the thumbs up. Thank You)
If I have solved your Issue please click the "Mark as accepted solution" button.
0 Ratings
Reply
anthonyUK
Expert
1,312 Views
Message 3 of 20

Re: Poor HH3 performance for 160Mbit FTTP

It could be that your laptop is not auto negotiating gigabit speeds correctly with the HH3. It does happen with various chipsets. Does it make any difference it you force the NIC to 1000 full duplex?

 

What does it show the connection speed as in the HH3 network devices?

0 Ratings
Reply
nigma
Contributor
1,297 Views
Message 4 of 20

Re: Poor HH3 performance for 160Mbit FTTP

Hi,

 

Laptop is showing speed as a gigbit connection in both Windows and in the hh3 network devices. The "slow" speed has been an issue with all my devices on my home network whcih are all connected via Gigabit.

 

But in anycase, I would expect above the 22mbit/s im seeing even on a 100mbit interface.

 

Just to add to that, I was getting pretty poor internal network transfer speeds until I added a gigabit switch to the network with all my home devices connected to that. My only connection to the HH3 is through the single gigabit port.

0 Ratings
Reply
Ratty2012
Recognised Expert
1,282 Views
Message 5 of 20

Re: Poor HH3 performance for 160Mbit FTTP


@nigma wrote:

Hi,

 

Laptop is showing speed as a gigbit connection in both Windows and in the hh3 network devices. The "slow" speed has been an issue with all my devices on my home network whcih are all connected via Gigabit.

 

But in anycase, I would expect above the 22mbit/s im seeing even on a 100mbit interface.

 

Just to add to that, I was getting pretty poor internal network transfer speeds until I added a gigabit switch to the network with all my home devices connected to that. My only connection to the HH3 is through the single gigabit port.


It sounds like you have a HH3a and not a HH3b, you need to check and if you do have a HH3a you need to ask BT to replace it.

0 Ratings
Reply
Highlighted
anthonyUK
Expert
1,271 Views
Message 6 of 20

Re: Poor HH3 performance for 160Mbit FTTP

But in anycase, I would expect above the 22mbit/s im seeing even on a 100mbit interface.

You would normally but if there is a speed or duplex mismatch then it is feasible. I've seen major issues with high end hardware from Sun and Cisco in the past.

 

 

0 Ratings
Reply
Deathtrap3000
Recognised Expert
1,247 Views
Message 7 of 20

Re: Poor HH3 performance for 160Mbit FTTP

Dont bother with the bt tester. Run a test from servers you know can handle the speeds and wont fluctuate. The same server on speedtest over a few hours is a good start.

0 Ratings
Reply
Steve25
Aspiring Contributor
1,242 Views
Message 8 of 20

Re: Poor HH3 performance for 160Mbit FTTP

I see similar issues on FTTC. Its the HH3. I have to keep swapping the speed on my NIC in the PC till the HH3 syncs back at the right Speed ie 1gbit. it a right royal pain.

 

probably an issue with the the Frimware on the HH3

 

Steve

0 Ratings
Reply
Ratty2012
Recognised Expert
1,236 Views
Message 9 of 20

Re: Poor HH3 performance for 160Mbit FTTP


@Steve25 wrote:

I see similar issues on FTTC. Its the HH3. I have to keep swapping the speed on my NIC in the PC till the HH3 syncs back at the right Speed ie 1gbit. it a right royal pain.

 

probably an issue with the the Frimware on the HH3

 

Steve


If you take auto negotiating off and force it to connect at 1gbit it should solve that.

0 Ratings
Reply
Locky
Expert
1,221 Views
Message 10 of 20

Re: Poor HH3 performance for 160Mbit FTTP

I would get rid of the HH3, it's a box of fail.

I would invest in a decent router, I know it's spending money, but you will be happier for it.