Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 3

Router disconnects every 45 minutes!! 2 year issue! PLEASE FIX

Every 45 minutes Router flashes purple for 20 seconds, then flashes orange for 20 seconds, then stops flashing but remains orange for 20 seconds, and then it comes back to blue and I have internet again. This genuinely happens twice every 2 hours, sometimes more, sometimes less. I’m into my online gaming and I’ve had to basically stop for the last year and a half because of it, but I want to get back into it again and the only way I can do that is if this issue gets sorted. I can’t keep disconnecting from games. It’s not good enough. 

I’ve had this issue for 2 years now. I ended MY contract a year ago, and since then somebody else in the house is paying for BT, and yet again the same issues. Constantly, for 2 years. When I had an account I had about 10 engineers out who all said the same thing (where every engineer tests it for an hour and then says “I don’t know, not much more I can do”).


It’s becoming a joke now. And I’d rather stick with BT and get it sorted than switch provider. Why can’t BT sort this for me?! It’s like because it’s a complicated technical issue nobody can be bothered to help me, it’s just a bunch of passing the buck and “sorry not my problem” stances. 

For some context of what I’ve tried to do on my own. I’ve spent a couple days going into my router settings and disconnecting all wireless devices from the router, and even when my Xbox is just connected through 1 Ethernet cable (and no other device connected to the router wirelessly or wired) it still happens, the router still goes through the weird purple/orange flashing reset thing.


I’ve changed from the 5 mhz thing to the 2.4 whatever it is, I’ve switched channels, I’ve reset to factory settings, I’ve had 10 routers sent to me all doing the same thing.


clearly there’s something wrong with my line, but nobody wants to be the person to suggest it for some reason, as if they lose some sort of bonus if they admit it or something! It’s crazy! I need some proper help because 6+ engineer visits haven’t worked and will not work again. I need some proper guidance here. Please



0 Ratings
Message 2 of 3

Re: Router disconnects every 45 minutes!! 2 year issue! PLEASE FIX

the likelyhood of 10 routers all have the same fault causing drop in connection cannot be cause so need to look elsewhere

which broadband do you have - FTTC fibre to cabinet and copper to your home or FTTP fibre direct to your home?

when you get new router do you use a new power supply?

do you have any house alarms fitted or any other devices connecting to the internet - smart things?

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Message 3 of 3

Re: Router disconnects every 45 minutes!! 2 year issue! PLEASE FIX

Hi, I’ve got the standard FTTC, basic fibre with like 30-40mb speed.


Yeah I’ve not used anything from the old routers every time I’ve used a new one, so new power supply and everything, I’ve tried both new and old before though. 

We have a smoke alarm? and we also have a hive heater & ring doorbell. We’ve had the issue before we had the hive installed, and before now I’ve disconnected the ring doorbell and the same issue. Just yesterday I also disconnected all wireless devices through the 192.168 router website thing. And even just on Ethernet it was still resetting. Same with the Alexa, disconnected that too, still happens. The only thing I haven’t considered is the smoke alarm but when you say house alarm I assume you imply more of the security alarms like if glass breaks or something? Because we don’t have that.


feel like everything I could try, I’ve done. This was an old house that didn’t have any access to broadband up until we moved here 2 years ago. We had BT install a line and everything though. So my suggestion would be they’ve botched it perhaps, but every time the engineer does a test it’s always showing as fine. So I’m just stuck. 




0 Ratings