cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,281 Views
Message 1 of 12

Slow loading of web sites

Hi,

I've been having problems with slow loading of web sites for weeks now.

Especially YouTube and Facebook, which only load partially, and usually never complete.

 

I have changed browsers, cleared history and cookies.

I have re-formatted and re-installed Windows 10.

I have used two other laptops,

Re-set router.

Bur the problem still persists (even on the other laptops).

 

I logged onto my router, and checked the speed, and it is correct at about 74.9Mb/s

Tried running speed test on browser on Windows, but does not complete.

I have the Fibre 1 package

 

Any ideas ?

 

Thanks

0 Ratings
Reply
11 REPLIES 11
1,280 Views
Message 2 of 12

Re: Slow loading of web sites

have you checked MYBT and switched of web protect?



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
1,249 Views
Message 3 of 12

Re: Slow loading of web sites

Web Protect is already switched off.

0 Ratings
Reply
1,242 Views
Message 4 of 12

Re: Slow loading of web sites

Parental controls also switched off in MYBT?



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
1,227 Views
Message 5 of 12

Re: Slow loading of web sites

Yes,

BT Parental Controls
BT Web Protect
BT Virus Protect
True Key

all un-activated
bt55.PNG

0 Ratings
Reply
1,226 Views
Message 6 of 12

Re: Slow loading of web sites

About 25% of the time it works fine, at full speed.
This can be morning, afternoon or evening though.
No specific time
0 Ratings
Reply
1,117 Views
Message 7 of 12

Re: Slow loading of web sites

I have this issue too on both computers using all browsers.  I have fibre and the speed doesn't seem to be an issue although the BT Speed Test doesn't appear to work. Was wondering if you ever had a reply or were able to fix it?

Having done some research it sounds like I have DNS issues possibly caused by the interaction between my Smart Hub and Windows 10 but I have no idea how to resolve that!!

 

0 Ratings
Reply
1,106 Views
Message 8 of 12

Re: Slow loading of web sites

0 Ratings
Reply
1,092 Views
Message 9 of 12

Re: Slow loading of web sites

Hi pippincp.

Thanks for the quick response. 

I'm a bit nervous about changing the DNS settings on my router as I read (somewhere!) that this could affect my BT TV.  Do you have any thoughts on that?

Kind regards

0 Ratings
Reply
1,087 Views
Message 10 of 12

Re: Slow loading of web sites

I should also have added that on a new thread that I started earlier Imjolly suggested that I turn off Web Protect.  I have now done that and so far all is good.  So I may wait and see if the problem returns before changing my DNS settings.  Then I hopefully will know which one worked.  Fingers crossed.

 

0 Ratings
Reply