cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newbie
339 Views
Message 1 of 5

Smart hub 2 fully set up with strong signal but won’t allow access to anything, e.g. twitter etc

I have just set up my smart hub 2 in my new flat. It has set up fully, the light on the box is blue and I have used the app to check signal strength in every room and it is strong. However, nothing besides the BT websites and app will load. YouTube acts like it is working but will not play any videos, twitter will not load new tweets, and safari will only open BT websites and nothing else. The only other thing I can do is send standard iMessages. I’ve tried getting through to someone over the phone but just sat on hold for a long time and then because the signal is so weak it they couldn’t hear me, and if I’m near the box there is 0 phone signal. Also tried to use online chat but no one is available. Any help would be greatly appreciated. 

0 Ratings
Reply
4 REPLIES 4
Highlighted
Sage
327 Views
Message 2 of 5

Re: Smart hub 2 fully set up with strong signal but won’t allow access to anything, e.g. twitter etc

Can you  post the hub connection stats from advanced settings/technical log/information.

0 Ratings
Reply
Highlighted
Newbie
309 Views
Message 3 of 5

Re: Smart hub 2 fully set up with strong signal but won’t allow access to anything, e.g. twitter etc

E0103C90-47BD-4F8A-AE1C-7EC4EFA81CB4.jpeg

0 Ratings
Reply
Highlighted
Newbie
294 Views
Message 4 of 5

Re: Smart hub 2 fully set up with strong signal but won’t allow access to anything, e.g. twitter etc

When I try to troubleshoot I am directed to this screen: 

A8DD08D1-A048-4D1F-B74E-B9081E9376A9.jpeg

And when I click the “link account to BT ID” button it just takes me to the home page with no option to link an account.  

0 Ratings
Reply
Highlighted
Distinguished Sage
Distinguished Sage
280 Views
Message 5 of 5

Re: Smart hub 2 fully set up with strong signal but won’t allow access to anything, e.g. twitter etc

You have only been connected for 8min but you have the max connection speed 80/20mb

have you turned off smart setup

https://www.bt.com/help/broadband/what-is-smart-setup-on-the-bt-hub--how-can-i-turn-it-on-and-off-



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply