cancel
Showing results for 
Search instead for 
Did you mean: 
jasyk34
Beginner
2,299 Views
Message 1 of 12

Terrible Wireless Speeds

I have read the other postings on the forum about poor wireless speeds with BT Infinity. When I first had infinity installed I was getting 22Mb download speed via wireless. I am now getting between 1Mb - 6Mb via wireless. I have tried all of the other channels and get the same result. There is no congestion on the channels as I have used inSSIDer to check that.  When connecting via ethernet I get 37Mb download speed. 

 

I would be happy getting the 22Mb download speed again over wireless but cant get anywhere near that now. Any have this issue ? I wonder if a new hub would make any difference ?

0 Ratings
11 REPLIES 11
tsrpint
Beginner
2,272 Views
Message 2 of 12

Re: Terrible Wireless Speeds

Hmm

I have exactly the same problem as you seem to have.

I have been onto india a number of times already and its no better.

Looking through the forum and the comments others have made they have come up with:

Resetting IP Profile, no idea how to do this myself but will be getting onto the helpline in a moment.

Someone had their PSU replaced and reset ip profile, that cured it..

Comments thas HH3 is unrelaiable on wifi.. nice to know but hopefully thats not the case I I have one.

Unsubscribe from BT Fon.. Not aware that I am subscribed but I am going to try this.

 

Anyone else out there with other things to add..

 

I find it really frustrating that my connection is so poor over Wifi.. I had a better connection with Talk Talk and this was not a fibre connection.

 

I will be a BT customer for a very short period of time if I cannot get at least 20meg connection over wifi.

 

There's a battle coming!!

 

All the best

 

 

0 Ratings
wedd1ng528
Aspiring Expert
2,260 Views
Message 3 of 12

Re: Terrible Wireless Speeds

If jasyk34 is getting a download speed of 37 mbps with an ethernet connection it cannot be his profile that is causing the problem. Whatever your profile is this is the max that you can expect. So if his DL speed is 37 mbps then I suspect his profile is set at about 39 mbps.

 

The best way to check is to do a check at speedtester.bt.com. This will show what the profile has been set at by the DSLAM.

 

The problem could be with the wireless router, the wireless adapter in the computer, distance from the router to the computer, type of walls between the router and the computer. RF interference etc. I suggest you download a copy of inSSIDer 2.0 and check your signal strength and whether you are operating on the same or adjacent channels to your neighbours.

 

wedding

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Mistakes and embarrasing goofs in e-mails are only discovered when you've sent them!
tsrpint
Beginner
2,233 Views
Message 4 of 12

Re: Terrible Wireless Speeds

I have lost count of the number of calls to the BT Call Centre I have made now. It drives you nuts.

 

They sent an engineer out to me today and the engineer tested the modem and the line and said that I was getting close to 40meg and 10 meg as I should. This was over ethernet cable.

When I hopped onto one of the many laptops here I was only getting 10meg download. To me this is unacceptable and its not just on the one machine.

The engineer said that it was likely to be the network card in the PC which I really did not buy into..

He said that Macs tend to have better cards than PC's.

I tried my daughters mac and got 37meg!!!

This threw me really as I could not argue with the result.

 

If I get new network cards for the PC's is the feeling here that I will cure the problem?

I feel as though I am being run round in circles.

 

Any advices anyone?

 

Thanks in advance.,

0 Ratings
jjgraphics
Recognised Expert
2,221 Views
Message 5 of 12

Re: Terrible Wireless Speeds

The problem could be with the drivers for the current network adapters. Make sure that you have the latest versions installed. Check with the manufacturers' web sites to see what the latest version is and download it if you are not up to date.

0 Ratings
NinjaZXR
Contributor
2,189 Views
Message 6 of 12

Re: Terrible Wireless Speeds

@jjgraphics - a good starting point right there.

 

@jasyk34 and tsrpint - If you want the best from your wireless network only use 802.11n hardware.

 

802.11g adapters, which have a theoretical max throughput speed of 54Mbps, give real-world speeds of half that, but usually less, so 10 - 12Mbps would be a reasonable download speed using 11g.

 

@anyone who couldn't care less Smiley Happy

IMO

I've read a few posts on this forum decrying the wireless speed on the HH3 as rubbish, but it just ain't so.
The HH3 has a lot of faults, I don't use it anymore, but the download speeds using decent wireless n adapters were as fast as ethernet.

0 Ratings
jcampy
Aspiring Expert
2,167 Views
Message 7 of 12

Re: Terrible Wireless Speeds

your most likley problem is that the lappys only have G speed adapters

0 Ratings
Highlighted
qi_master
Aspiring Contributor
2,133 Views
Message 8 of 12

Re: Terrible Wireless Speeds

Try logging into the router and change the broadcast type to b and g only

i have seen this with a couple of HH3

0 Ratings
Tillypup
Aspiring Contributor
2,095 Views
Message 9 of 12

Re: Terrible Wireless Speeds

My experience is that the HH3 wireless is poor, particuarly with N capable devices. I've setup my HH2 as a wireless access point connected via cable to the HH3 using this article - http://www.jarviser.co.uk/jarviser/repeaterhubswired.html. If you still have your HH2 it might be worth a try, all of my wireless connections are rock steady now and have consistent performance which matches the cabled speeds as well.

 

I suspect that there is a performance issue with the HH3 iteself or the current firmware, which causes issues with the wireless throughputs and stability.

 

IMHO the HH3 is a pile of junk and as soon as I can decide what to replace it with, it'll be going in the bin.

0 Ratings
Chris-Sharpe
Contributor
2,089 Views
Message 10 of 12

Re: Terrible Wireless Speeds

You must set it to the 40hz N mode setting on the home hub, not any other option. If you multi broadcast g aswell it will only get half the speed like sombody said earlier in this thread.

I had this problem too, this should fix it.

0 Ratings