cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
symbol-soup
Aspiring Contributor
768 Views
Message 1 of 29

Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

Hoping for a bit of help on this one from the MODS.

 

Background
I work in IT and have done for 28 years. Part of that time was spent being a network engineer so I "know my onions".  The speed tests I refer to below were from fast.com / speedtest.com / BT

I ordered Ultrafast 900 from BT and Openreach duly turned up to install the ONT and run the fibre. He plugged in the Smart Hub 2 and told me I was live and ready to go. I didn't check speeds as with it being Fibre I just expected it to work out of the box - This was a mistake.

I connected my laptop later on that day to test out the connection.  This as directly into the Smart Hub via a Gig Ethernet network card.  However, speeds were nowhere near the advertised rates. I was getting the following results

Ping 6ms
Download 300-350
Upload 50

I decided to discard the hub and plugged my laptop directly into the ONT, setup the connection and ran a series of speed tests.

Download 300-350
Upload 100-120

I then plugged the Smart Hub back in to see what results I had.

Download 300-350
Upload 50-52  - Not sure if this related to another thread I've just read about throttling being active on the Smart Hub 2.

I then ran the BT speedtest that you can access via the Smart Hub 2. According to that, I was getting
Download 972
Upload 51


I called BT to raise a fault and was told they would send an OpenReqch engineer round. He checked the light coming down the cable, said that it was excellent so no issues there. He switched out the ONT just in case that was faulty but it didn't make any difference. We also replaced the network cables we were using. He couldn't get anything faster than I had (directly connected to the ONT). There were also no faults on the ONT at the management end.

I contacted BT again and they said the Openreach engineer had closed down the ticket as they were happy with the installation.  BT re-ran their speedtests and are adamant that I'm getting the throughput below
Download 924-975
Upload 50-51

BT have now said they'll send Openreach around again but they're just going to say everything is okay with the installation.

By connecting directly to the ONT via Gig E, I have ruled out it being anything in the house so it's definitely either BT or Openreach.

Can one of the BT mods in here get this escalated as I'm paying for a service BT say I'm getting, but in the real world I'm not getting the stay fast guarantee.

 

 

0 Ratings
Reply
28 REPLIES 28
NeilO
Moderator
Moderator
737 Views
Message 2 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

Hi @symbol-soup welcome to the community and thanks for posting, I'm sorry to see you're having problems with your FTTP broadband speeds. The stay fast guarantee is to your Hub and not the device and this is where the MyBT speed test measures the speeds from. There does appear to be an issue with the upload speed and we should be able to assist you with that and we'll be happy to check over the connection.

I'll send you a private message so you can get in touch with the moderation team, you'll get the private message by clicking on the envelope in the top right of the community.

Thanks

Neil

0 Ratings
Reply
symbol-soup
Aspiring Contributor
726 Views
Message 3 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

Thanks @NeilO  .   I appreciate you looking at the upload speeds.  Your answer about speeds to the hub doesn't really answer my question as to why I'm only seeing 350 meg downloads when I'm directly connected to the ONT though. 

0 Ratings
Reply
pippincp
Sage
686 Views
Message 4 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

What result do you get with THIS speedtest when connected to the ONT?

0 Ratings
Reply
Carlusha
Recognised Expert
662 Views
Message 5 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

Also note the helpful points in the drop down on @pippincp 's recommended test page.

When testing 500Mb/1000Mb speeds via a computer based device the results are dependent on the capability of the device and the premises environment.
In addition to the standard guidance provided in the ‘Before You Start?’ section you need to ensure that the customers device meets the following minimum specification:

  1. Processor should be above or equivalent to Intel® Core™ i5-4570S Processor (4 cores, 3.80 max Turbo frequency, 2.90GHz processor frequency, 6MB smart cache)
  2. Ensure that at least 4 GB of RAM is free
  3. 1 GB NIC card is recommended
  4. Ethernet cable should have the capability to transfer 1GB data
  5. Operating System - Windows 8 and above
  6. Minimum browsers supported - Google Chrome Version86, CX's Internet Explorer 11 as well as Microsoft Edge 2020 browsers version9 (2018 IE is not compatible)
  7. Please ensure you are using the latest browser version for optimum results.

NB: To ensure accurate results please ensure you are testing via a wired connection with all other devices disabled, or switched off when running the test.

0 Ratings
Reply
pippincp
Sage
654 Views
Message 6 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

@Carlusha  Did you miss this bit? "I work in IT and have done for 28 years. Part of that time was spent being a network engineer so I "know my onions".

0 Ratings
Reply
symbol-soup
Aspiring Contributor
641 Views
Message 7 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution
I should have said, I've also tried this as well as nperf. Download speeds are never greater than 350. Upload is 100
0 Ratings
Reply
symbol-soup
Aspiring Contributor
637 Views
Message 8 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

Thanks for this but my equipment exceeds all of those specs. The mods have been in touch so I'll post on here once there are some updates.

0 Ratings
Reply
symbol-soup
Aspiring Contributor
636 Views
Message 9 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution
🙂
0 Ratings
Reply
ch
Contributor
624 Views
Message 10 of 29

Re: Ultrafast 900 FTTP - Real world experience - Only getting 1/3 of throughput BT say I'm getting

Go to solution

Have you tried a second machine connected hard-wired?

Have you proved that your laptop ethernet port is capable of transferring data at gigabit speeds (perhaps from an internal source/server - some aren't, depending how cheap the manufacturer was with the chipset/bus architecture)?

I had some luck on one machine that was performing poorly by running TCPOptimizer. I suspect something had screwed with the ipstack settings somewhere along the line. A fresh build of Windows 10 didn't need tweaking to perform at the maximum throughput.

 

0 Ratings
Reply