cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
566 Views
Message 1 of 5

Upgraded to BT 900 and speeds stuck at sub 50mb

Screenshot_20220622-090042_ASUS Router.jpg

Screenshot_20220622-212713_ASUS Router~2.jpg

Hi.

 

In December I took out the BT 500 package and always had decent speeds down(450mb+).

 

Yesterday I upgraded to the 900mb package and it went live some time in the early morning today. I was getting recorded speeds between 700-850mb consistently to the router but at 4pm I lost connection for about 20 seconds. 

Funnily enough, at about that time I noticed a Facebook post in my town group regarding people losing FTTP connection with sky, BT and Vodafone. Most have lost all connection but some say theirs still works.

Since then I've been floating between 7mb and 55mb which is absolutely disgraceful. Although the upload is a healthy 110mb. I've spoken to various representatives with varying levels of assistance and it's driving me nuts.

I use a third party router which after mentioning this all of the tech support dismiss any evidence of speed tests and what I've heard from people regarding a local issue and either try to charge me £85 for a openreach engineer or just say plug my original BT router in and wait  A WEEK so their system picks it up and that can "diagnose" it.

It was working fine all day up until 4pm then it all went south. If it's a local issue then fine but don't try and charge me £85. 

I also understand the line has to settle in but you don't go from 850mb to 10mb. That isn't settling in.

 

Apologies if I'm coming across as stroppy but I'm getting married at the weekend and with 2 kids who use the internet alot, hence why we pay for the top tier package, is another unnecessary thing to stress about. Our line was spot on with the 500mb package and my 3rd party router.

 

If anyone can assist and look into this it would be greatly appreciated. Thank you.

 

0 Ratings
Reply
4 REPLIES 4
551 Views
Message 2 of 5

Re: Upgraded to BT 900 and speeds stuck at sub 50mb

Did you check to see if there is a service problem in your area?  You can check by going to 'help' at top of forum page and check service in my area



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
541 Views
Message 3 of 5

Re: Upgraded to BT 900 and speeds stuck at sub 50mb

That just sends me round in circles due to not using BT's router.

Im assuming you mean the help tab in the menu drop down box?

0 Ratings
Reply
526 Views
Message 4 of 5

Re: Upgraded to BT 900 and speeds stuck at sub 50mb

I mean the 'Help' at top of the forum next to MY BT then check service in my area and then enter phone number - for a change this actually works with DV lines



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
514 Views
Message 5 of 5

Re: Upgraded to BT 900 and speeds stuck at sub 50mb

I don't have a land line being on FTTP so I can't check.

 

Day 2 of BT 900

Screenshot_20220623-061434_ASUS Router~2.jpg

 Just spoke to my parents who live literally 2 seconds around the corner, their BT 100 has been down since 7pm last night and remains down. Obviously a bigger issue at large.

 

Could someone have a look at my sync rates / profile to make sure i've not somehow ended up on a lower sync speed. I just worry that as the switch over happened as a local fault developed im going to get stuck on a slow speed due to the issues.

0 Ratings
Reply