cancel
Showing results for 
Search instead for 
Did you mean: 
jaytelford
Contributor
1,590 Views
Message 1 of 11

After updating Galaxy S9 to android 9 WiFi calling no longer works

Hi,

I have a Galaxy S9 purchased directly from BT. This morning it updated to Android 9 and now WiFi calling no longer works

All calls and texts are going over a regular cellular network. The WiFi calling icon is not displaying in notifications - it's just showing VoLTE.

Additionally when making a call, the call button no longer shows it as a WiFi call.

All the settings on my phone related to WiFi calling are switched on and WiFi calling worked prior to updating to Android 9.

I have tried turning off and on the WiFi calling settings - it doesn't work. I have restarted my phone, that doesn't work either.

My preferred option is to have WiFi calling work again. If that is not possible, how do I go back to the pre-update software version so I can get WiFi calling back again?

Is it possible for BT to describe and reactive WiFi calling on my account, would that force my phone to redownload the correct carrier settings or something?

Any help appreciated

Jason
0 Ratings
Reply
10 REPLIES 10
Bezman
Beginner
1,579 Views
Message 2 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

I had the same problem with my Galaxy Note 9 and all i did was do a factory reset and hopefully it'll come come like it has on my phone.

 

Hope this helps

0 Ratings
Reply
jaytelford
Contributor
1,533 Views
Message 3 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

Still having problems with this. I am now getting quite agrivated that BT sold me this device by advertising it had WiFi calling and saying nothing about WiFi calling being broken by future software updates.

Nothing I have done, including resetting has worked, which means I am without the feature I purchased this device for.

Very frustrating
0 Ratings
Reply
pete_S
Aspiring Contributor
1,488 Views
Message 4 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

I have a similar problem with my OnePlus 5T since upgrading it to Pie.  For me, WiFi calling will only work very occasionally - mostly it defaults back to VoLTE.  A work around I've found is to enable airplane mode, then manually turn on WiFi and BlueTooth - i.e. completely disable the mobile stack.  I think my problem is specific to OnePlus TBH (and their support is worse than useless), but might be worth a try.

0 Ratings
Reply
Bezman
Beginner
1,476 Views
Message 5 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

Wifi calling will kick in if you don't have a 4g signal so if you do have a signal it will be volte. But if you want wifi calling turn your 4g off in network mode.
0 Ratings
Reply
pete_S
Aspiring Contributor
1,469 Views
Message 6 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

On my 5T, I can set a preference - Wifi Calling or VoLTE. I have Wifi as preferred, so it uses Wifi, then 4G, then mobile. However, as I said, it doesn't work reliably on Pie - and I have to turn the mobile stack completely off using Airplane mode - then it work. Turning off data but leaving mobile enabled doesn't fix it.
0 Ratings
Reply
Andyneouk
Aspiring Contributor
1,457 Views
Message 7 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

i think samsung changed the wifi calling threshold. i noticed that since i moved to Pie (android 9) on my s9+ that wifi calling isnt active as much. this looks like its because i have a strong 4g signal at home. if you go in to mobile connection settings and set the phone to use 2g/3g (not 4g / lte) then wifi calling should kick in. at least thats what i found. at first i was a bit annoyed but it makes sense.

0 Ratings
Reply
Highlighted
wendymurray3
Aspiring Contributor
1,341 Views
Message 8 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

I have just got a software update today and same thing for me wifi calling has disappeared. Thing is I really need it in the house as we have a terrible signal. I read the fix above to turn off 4g, so does this mean that every time you leave the house you have to turn 4g on and off again?
0 Ratings
Reply
pete_S
Aspiring Contributor
1,330 Views
Message 9 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

The only way I can make it work reliably is to turn on airplane mode, then turn WiFi back on. Then, turn airplane off when I leave the house. I've setup activity in automagic to alert me when I disconnect from home. Pain in the bum. I have a oneplus 5t, and I've seen the same problems on Nokia, so I think it's by design in Pie sadly.
Bob1944
Beginner
882 Views
Message 10 of 11

Re: After updating Galaxy S9 to android 9 WiFi calling no longer works

 It seems to be a problem with the new Android 9.0 (Pie) operating system.  I have found three workarounds, which seem to offer temporary solutions.

The easiest option is to enable Flight mode, which will decativate cellular, Bluetooth and WiFi connectivity.  Then, reactivate WiFi alone (plus Bluetooth, if required).  That will restore WiFi calling.  It works well whilst you are at home or in your workplace, provided you have a reliable WiFi signal.  However, you must remember to turn off Flight mode, when you leave your home or workplace.

The second option is to open Settings > Connections > Mobile networks and turn off VoLTE calls.  Again, you must remember to turn on VoLTE calls again, when you no longer have access to a WiFi signal.

The third option is very similar.  Open the Mobile networks menu and change the Network mode to 3G/2G (autoconnect).  Again, you must remember to revert to LTE/3G/2G (autoconnect), when you no longer have access to a WiFi signal.

0 Ratings
Reply