cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Aspiring Contributor
377 Views
Message 1 of 3

Moto E6 Plus mobile details wrong and no WiFi calling

Hi recently got a new Moto E6 Plus SIM free and put my existing family SIM in. On my bt it still shows old phone, imei number and no WiFi and 4g calling. Have searched the forums and done as instructed, sent txt with old phon and put SIM back in New etc etc. But mybt still shows old details. Also my phone supports WiFi calling and this is enabled in settings and it has latest Android 9 updates to August 2020 release. I have fttp smart hub for WiFi but very patchy phone signal here so kinda need it. 

Btw, we have 3 family Sims all in 3 identical SIM free phones, and mybt says 2 are old details and 1 has no details.

My neighbor has same fttp smart hub and identical phone, no phone signal like us but WiFi calling does work and his detail are correct on his mybt account.

Can somebody please help as we're considering making the move to another provider for phone, broad band and mobile as we really need to be able to take calls in our house on mobile number.

Many thanks

Craig

0 Ratings
Reply
2 REPLIES 2
Contributor
320 Views
Message 2 of 3

Re: Moto E6 Plus mobile details wrong and no WiFi calling

The incorrect details on MyBT shouldn't affect the service from working. I use an iPhone 11 Pro that i got from BT last year, and it shows on my MyBT that i also don't have wifi calling, however it's worked fine since day 1 as i don't get signal at home without it.

 

I think to actually get your online account updated to show the correct details, you may need to call customer service as it could be an issue with your online account.

0 Ratings
Reply
313 Views
Message 3 of 3

Re: Moto E6 Plus mobile details wrong and no WiFi calling

MyBT tells me that I don't have wi-fi calling but I do.

The notification telling you that don't have it is based on the most inaccurate, incomplete and outdated records anyone could possibly imagine and has nothing to do with fact.

To test your Wi-Fi calling, try the following.

  1. Put your phone in flight or aeroplane mode.
  2. Re-enable Wi-Fi (step 1 will disable it)
  3. Make a phone call.

If the call is successful then Wi-Fi calling is working, if it doesn't then it's not


If you found this post helpful 🙂 then please let me know by clicking the thumbs up button below. On the other hand, if you found it unhelpful 😞 then please let me know by clicking the thumbs up button below . 😄
0 Ratings
Reply