cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Beginner
199 Views
Message 1 of 2

MyBT app

My samsung 3mini says:  your device isn't compatible with this version.  What can I do to get the app on my phone, is there a way to get an older version??

0 Ratings
Reply
1 REPLY 1
Highlighted
Community Manager - Retired
164 Views
Message 2 of 2

Re: MyBT app

Hi @Cathiee The My BT app requires Android 4.3 and up, and I believe that Samsung has stopped providing updates for the S3 Mini (happy to be corrected if I'm wrong!), so it looks like your device isn't able to support the app. I'm sorry about this.

0 Ratings
Reply