cancel
Showing results for 
Search instead for 
Did you mean: 
stewartv
Contributor
390 Views
Message 1 of 4

BT Community fails to recognise domains with the "-" character

  • Hi.

I have a regular MyBT account which uses my email domain stewart@xxxx-yyyy.co.uk with no issues.

I tried changing my BT Community email address to match and no verification message was received. I then tried a gmail address which worked.

The verification email never arrived with my ISP (no junk or spam filters in use).

I have had this issue with a few companies including ebay! Can someone check the community email system as it should allow for the  "-" character in an email domain when checking the validity of characters. As mentioned, the MyBT systems all work OK and I receive account emails, product info etc with no issues.

I am sure that I cannot be alone in experiencing this?

Many thanks .

Stewart

3 REPLIES 3
-Richie-
Expert
378 Views
Message 2 of 4

Re: BT Community fails to recognise domains with the "-" character

You really need to remove your email address from a public forum, everyone here are customers, only the moderation team are employees.
If required you'd be contacted by private message, then sharing your email address would be safe.

Highlighted
stewartv
Contributor
371 Views
Message 3 of 4

Re: BT Community fails to recognise domains with the "-" character

Thanks. Edited post.

I could not find any other place to ask such a question.

Moderator
Moderator
338 Views
Message 4 of 4

Re: BT Community fails to recognise domains with the "-" character

Hi @stewartv welcome to the community and thanks for posting, I'm sorry to read about the problems you had using your email address that contained a hyphen when registering for the community. I'll raise this with the community manager when he's back in the office tomorrow.