cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
waysu
Beginner
876 Views
Message 1 of 5

Brand new install, no hub delivered and apparently my fault

I placed an order via the web on 17th November for fibre broadband at our new house. We only moved in a couple of weeks ago so I've never had broadband at this house. Since then I've been struggling working from home over a low strength Bt/Fon wi-fi broadband connection which regularly cuts out. So I was looking forward to getting fast and reliable broadband when it gets activated today.

The engineer turned up today and did the install and I've been waiting for a delivery of the hub which hasn't arrived. I just phoned up customer services and apparently it's my fault because I didn't place an order for the hub!?

What the hell? How can you place an order for a brand new broadband installation without it automatically ordering you a hub? Also why is not obvious (to someone who writes software for a living) that I need to tell it to send me one?

Apparently an order for a hub will now be raised, but can't be until my current order (without a hub) is closed off tommorrow. Then apparently I'll be told how long before I will get delivery of a hub (given the above, I'm not holding my breath.)

This is my first experience with BT for many years and, needless to say, I am not very happy.

0 Ratings
Reply
4 REPLIES 4
PaddyB
Moderator
Moderator
862 Views
Message 2 of 5

Re: Brand new install, no hub delivered and apparently my fault

Hi @waysu,

I'm sorry the Hub wasn't included as part of your order. I can help you get that ordered. Please can you send me in your details using the "Contact The Mods" link found in my profile?

Thanks

PaddyB

0 Ratings
Reply
waysu
Beginner
845 Views
Message 3 of 5

Re: Brand new install, no hub delivered and apparently my fault

Hi, thanks, I'm logged in and viewing your profile page but there is no "contact the mods" link only a message button which takes you to compose a private message (which I'm not supposed to send details through according to your banner.)

0 Ratings
Reply
NeilO
Moderator
Moderator
796 Views
Message 4 of 5

Re: Brand new install, no hub delivered and apparently my fault

@waysu I'm really sorry about that, if you click on my username you'll see the'click here to contact the mods' link.

0 Ratings
Reply
waysu
Beginner
785 Views
Message 5 of 5

Re: Brand new install, no hub delivered and apparently my fault

Ok thanks. Sent my details, don't know my account number but could provide the order number if required.
0 Ratings
Reply