cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,061 Views
Message 31 of 36

Re: BT Cloud Windows Client version 21.8.9

@RTLThank you.

I have used a browser on many occasions for downloading individual files, and I confirm that still continues to work. However, to synchronise a large number if random files using a browser is somewhat messy, and re-downloading files that are already synchronised wastes a lot of time.

In the past, I have tried uploading complete folders via a browser, and I discovered that some files were created in the Cloud copy but were left empty. Using the desktop client used to be a reliable way to complete an upload and download of new or modified files, but no longer seems to work on my 8.1 system even when I restored C: the the state it was in when it last worked. (I keep several images of C: of my various PCs so I can roll back when something goes wrong. The fact that this hasn't worked suggests to me that that the server component in the BT Cloud has suffered an incompatible change.)

0 Ratings
Reply
1,050 Views
Message 32 of 36

Re: BT Cloud Windows Client version 21.8.9

@str8chat  Hello.   I have this laptop that originally came with Windows 8 but I have been running Windows 10 on it. 

So today, I downloaded the ISO for 8.1 and installed it. What a pain---it then needed 134 updates applied!!Anyway brought it up to date and have set Edge to be the browser same as yourself. Only other things I installed were Belarc Advisor and Macrium Reflect 8 Free so I could take images. That all worked fine.

I then installed BT Cloud 21.8.9 and it went on o.k.  I only use sync but the files  have all downloaded.

End result is 21.8.9 has no problem running on Windows 8.1 for me. 

I've only got Windows Defender on. Maybe you have some other antivirus that could be interfering with the install. I would try disabling it---if applicable.  

 

Extracts from Belarc ReportExtracts from Belarc ReportBT Cloud 21.8.9BT Cloud 21.8.9SyncingSyncing

0 Ratings
Reply
1,019 Views
Message 33 of 36

Re: BT Cloud Windows Client version 21.8.9

@RTLThanks for your response and for the efforts you have made to show that the latest client works with at least one 8.1 system.

I tried rolling my 8.1 laptop back to a C: image from about 5 or 6 months ago when it was working. This wasn't just uninstalling updates, but was a complete restore of the whole of C: to that particular time. As soon as I tried starting the BT Cloud client it failed. within a few seconds. The only explanation I can think of is that BT have made some change that is incompatible with something on my PC. The PC has Kaspersky Internet Security which has never caused this problem before and which was rolled back to the same state it had been when it last worked. I disabled that, and tried again with a new install of the client. The results were exactly the same.

There are a large number of other Apps on the PC that I use, and I didn't feel like wasting my time trying to wade through them removing them one by one. I have a suspicion that I could remove all the extra Apps I have installed, and it probably still wouldn't work.

I decided that, as there was quite a bit of free space spread between C: and D:, I would shrink C: slightly, move 😧 down to sit back on top of C: and with a slightly smaller 😧 that left me with plenty of space for a new partition to hold Windows 10. I installed Windows 10, which activated without any issue, and installed the BT Cloud client, which is working very well. I have removed the drive letters for the two Windows partitions from the opposite operating systems, so both have C: for Windows and Apps, and share 😧 for data.

I have found a number of issues over the last couple of years with the way the BT Cloud client works. I have a cheap mini-desktop PC with a 32GB eMMC drive holding Windows 10, and a 500 GB HDD. I use this for two main purposes - one, as a repository for files I want to save, and two, as a Linux development platform for any little utilities I want to write. I put my files in the repository (BT Cloud folder) and start the client, and leave it to upload to the Cloud. In tests over the last two or three years, since I started using the Cloud storage that is provided as part of my broadband contract I have found a few little glitches.

At one point I uploaded a thousand or so photos filed in around 20 folders, and uploading them through the browser interface rather than using the client App. When I tried the corresponding download, about half a dozen files came back as empty files. On investigation I found that the Cloud copies of those files were missing their data although the file names were there. I cleared the Cloud space down and repeated the upload and a similar thing happened but with different empty files.

Then I experimented using Sync. This worked fine for the upload to the Cloud, but failed on the download on my mini PC. It appears that on uploads, the client seems to pull the data directly from the repository folder, but on download it brings the data into the users appdata\local\temp folder on the C: drive and when a file is complete it moves the data to the actual folder where it should be. This has two issues for me:

First, the process of moving the data from C: to 😧 on my PC involves a copy and delete rather than a move as they are on different logical drives (C: and D:). This wastes time and resources on the PC, and with flash storage such as eMMC or SSD, the extra writes of the data can be detrimental to the life of flash devices.

Second, I have about 75 GB of data in over 14000 files comprising music, photos and video clips, some of which are up to around 2.5 GB in size. For some reason, at times the client downloads several files at the same time rather than using the whole bandwidth for one file at a time. Assuming the bandwidth of my Internet connection is going to be the limiting factor, then it should take the same time to transfer multiple files in parallel as it does to transfer the same files sequentially. On my mini-PC with only a 32 GB drive for C:, when multiple 2 GB files are downloaded in parallel C: can fill up and all the files in transit fail. To me it would seem much more sensible to download the files one at a time, and store them with in a temporary folder on the actual destination drive (in my case D:). That would eliminate the problem of running out of space on C:, and also allow the file simply to be moved (rather than copied and the original delete). This would be much faster, less resource intensive and more write friendly to flash storage devices.

The first time I tried a complete download of my Cloud data using sync with the latest client, three of the 14000+ files failed to appear on my PC. Admittedly the client did not declare that it had finished, but even waiting an extra 12 hours the missing files did not appear. I stopped and restarted the client and the missing files arrived within half an hour.

On another attempt on a different Windows 10 system one file was not fetched and again the client just hung around apparently doing nothing. That also recovered after the client was restarted.

I have developed a small Linux script that allows me to capture the path and file names with the sizes in sectors and a simple sum-check for each file and save this in a check file. I now run this script on the repository PC and any PC that I have used to download my Cloud data and simply diff the two check files. This instantly highlights any issues and has convinced me not to trust Cloud storage without checking that it has saved my data correctly.

I have logged my issue of the latest client not working with my 8.1 system and this is currently with tier 2 tech support at BT.

0 Ratings
Reply
885 Views
Message 34 of 36

Re: BT Cloud Windows Client version 21.8.9

Three issues for me.

1. Limited to 9.8 GB per file

2. Annoyingly pops up whenever a sync is performed (continuous option selected). If I can turn that off I would only have two issues. 🙂

3.  For some reason an error occurs, the green cloud goes red and BT Cloud stops syncing. If it's the file size I would expect the system to ignore the file (or simply report it) then continue to the next file.

For these reason I turned BT Cloud off and decided to take another look, still has these issues.

0 Ratings
Reply
618 Views
Message 35 of 36

Re: BT Cloud Windows Client version 21.8.9

Good afternoon,

Could you kindly update the User Guide to reflect the changes to the latest version, please?

If you refer to my recent post, you'll see I had horrendous problems installing BT Cloud, most (all?) of which could have been avoided with the correct information.

Thank you.

0 Ratings
Reply
587 Views
Message 36 of 36

Re: BT Cloud Windows Client version 21.8.9

Although this thread refers to version 21.8.9, I believe the current version as of July 2022 is 21.12.15.

I have recently discovered several features (for want of a better word) that should be quite concerning to users of BT Cloud and possibly other Cloud systems. I have around 75 GB of data in around 600 folders and over 14,000 files, which are mainly photos and family videos, although I do have some other files stored in the Cloud.

I have just set up a couple of new PCs, and I decided to synchronise the two PCs and load all the Cloud data onto them. I chose not to copy the data using an external hard drive but let both PCs synchronise with the BT Cloud copy of my data. When they had finished, I opened the Properties of the top level folder for the synchronisation on each PC to check on the number of files and disk space usage. One PC showed one more file that then other one, and there was also around 1.8 GB difference in the total file size across the 14,000+ files. Checking back with one of my other PCs showed that one of the new machines had picked up an extra file, rather than the other new PC losing one.

I booted each PC from a Live Ubuntu Linux USB pendrive and ran the following shell script on both:

NAME="`pwd`"
NAME=`basename "$NAME"`

find . -type f|while read -r line
do
sum -s "$line"
done|while read num1 num2 rest
do
echo $rest $num1 $num2
done|tee ~/sumcheck.tmp

sort ~/sumcheck.tmp >~/"$NAME".sumcheck
rm ~/sumcheck.tmp

This script produces a sorted list of all the files with their paths relative to the current directory when the script is run and appends to the end of each line a 16-bit sum-check and a count of the number of sectors in that file. Using the Linux 'diff' command on the results from the script immediately showed the lines of files that I needed to check. One file appeared to be a duplicate of another file in the same directory. It had the same name but had the words "conflicted" and "copy" added in the file name. This was the extra file that the Properties check had shown.

The other two lines shown by 'diff' were a different file in the same directory that was showing a different sum-check values on the two new PCs. Fortunately, I had only allowed the BT Cloud App to be running on one of my PCs at a time. What I found was that the second of the two new PCs had a corrupt version of this one file. On further investigation I found that the copy of that file in the Cloud had the same corruption. I opened the Cloud App on the PC with the corrupt file, and looked at the progress log, which only shows the last few entries.

Does the BT Cloud App maintain a full log file that can be checked?

One of the last entries was an upload of the corrupt file from that PC to the Cloud. It looks as though the PC somehow corrupted the file and then the App uploaded the corrupted version as though it had been edited.

Before replacing the corrupt file with a clean version, I restarted the Cloud App on my other new PC, which downloaded the corruption from the Cloud. This is potentially very dangerous if you rely on the Cloud to synchronise files across all your PCs as a corruption could be propagated to them all. I deleted the corrupt file from the affected PCs and the Cloud and then reloaded a correct version which was correctly uploaded and distributed to the affected machines.

As I have mentioned on a previous post, I still hate the way that the App downloads files from the Cloud when syncing. It downloads the files into temporary space on C:, and then moves the complete file to its final destination. One on of my new PCs, the final destination - the only drive that had sufficient free space - was on an external USB2 connected HDD. At USB2 speeds, it wasted around 30 minutes moving the 75 GB of files individually from C: to the external drive. If it had used a temporary folder on that external drive, this time would have been saved as moving a file within a file system is almost instantaneous. Also, if the drives had been flash drives, it would reduce the amount of unnecessary write operations that the flash storage would experience and which potentially reduces the life of flash storage.

As I have also mentioned in a previous post, the Cloud App can download multiple files in parallel. As some of my files are over 2 GB in size, when several of these files are downloaded at the same time, the free space in C: can disappear and the App stops working. Although I normally try and keep some free space in C: I don't see why it is necessary to have perhaps 10 to 15 GB of space left empty in C: just so that the App has some temporary storage available, when there could be plenty of spare space for temporary storage on the final target drive. To me this shows sloppy design in the way the App works when downloading from the Cloud.

One final point. I use Firefox as my default browser, and when I was checking the corrupted file, which had an .MP4 extension, Firefox changed the .MP4 to .3gp. If I download multiple MP4 files, to be delivered as a ZIP file, they arrive as MP4s. It is only when downloading a single file using the browser that I have seen this, and for some reason it happens only with certain large MP4s. Small MP4s don't seem to suffer this problem. Also, I have not seen this when downloading the same MP4 files using Firefox from Google Drive. I have only seen this downloading in Firefox and only from the BT Cloud.

0 Ratings
Reply