cancel
Showing results for 
Search instead for 
Did you mean: 
canatan
Newbie
633 Views
Message 1 of 2

Ubuntu 14.04 BT Wifi FON connection issues

I've been trying to connect to BT Wifi with FON. It connects to the network but no login page shows and when it does its very slow and i can not get past it. My friend with a MAC is easily able to connect to BT Wifi with FON. We're literally in the same room. Here are the results from running the ubuntu wireless script.

 
########## wireless info START ##########

Report from: 21 Feb 2017 13:40 GMT +0000

Booted last: 21 Feb 2017 12:27 GMT +0000

Script from: 08 Jul 2016 02:16 UTC +0000

##### release ###########################

Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.5 LTS
Release:	14.04
Codename:	trusty

##### kernel ############################

Linux 4.4.0-63-generic #84~14.04.2-Ubuntu SMP Mon Feb 13 11:04:58 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

02:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
	Subsystem: Bigfoot Networks, Inc. Device [1a56:1535]
	Kernel driver in use: ath10k_pci

##### lsusb #############################

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0cf3:e300 Atheros Communications, Inc. 
Bus 001 Device 003: ID 0c45:6713 Microdia 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

##### lsmod #############################

dell_wmi               16384  0 
ath10k_pci             40960  0 
ath10k_core           311296  1 ath10k_pci
ath                    32768  1 ath10k_core
mac80211              733184  1 ath10k_core
cfg80211              561152  3 ath,mac80211,ath10k_core
mxm_wmi                16384  1 nouveau
video                  40960  3 i915_bpo,dell_wmi,nouveau
wmi                    20480  4 dell_led,dell_wmi,mxm_wmi,nouveau
sparse_keymap          16384  2 dell_wmi,intel_hid

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF1]>  
          inet addr:10.252.215.21  Bcast:10.252.215.23  Mask:255.255.255.248
          inet6 addr: fe80::<IP6 'wlan0' [IF1]>/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5412 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6532 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3606514 (3.6 MB)  TX bytes:758255 (758.2 KB)

##### iwconfig ##########################

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"BTWifi-with-FON"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]>   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=39/70  Signal level=-71 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:9  Invalid misc:0   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.252.215.17   0.0.0.0         UG    0      0        0 wlan0
10.252.215.16   0.0.0.0         255.255.255.248 U     9      0        0 wlan0

##### resolv.conf #######################

nameserver 127.0.1.1
search home

##### network managers ##################

Installed:

	NetworkManager

Running:

root       807     1  0 12:27 ?        00:00:07 NetworkManager

##### NetworkManager info ###############

NetworkManager Tool

State: connected (global)

- Device: wlan0  [BTWifi-with-FON] ---------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath10k_pci
  State:             connected
  Default:           yes
  HW Address:        <MAC 'wlan0' [IF1]>

  Capabilities:
    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    TALKTALK08B3D0:  Infra, <MAC 'TALKTALK08B3D0' [AN1]>, Freq 5180 MHz, Rate 54 Mb/s, Strength 74 WPA WPA2
    TALKTALK08B3D0:  Infra, <MAC 'TALKTALK08B3D0' [AN2]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
    SKY82CF1:        Infra, <MAC 'SKY82CF1' [AN3]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 47 WPA2
    BTHub5-ZHKS:     Infra, <MAC 'BTHub5-ZHKS' [AN4]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 49 WPA2
    SKY147BC:        Infra, <MAC 'SKY147BC' [AN5]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 44 WPA2
    BTWifi-X:        Infra, <MAC 'BTWifi-X' [AN6]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 44 WPA WPA2 Enterprise
    BTWifi-X:        Infra, <MAC 'BTWifi-X' [AN7]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 49 WPA WPA2 Enterprise
    BTHub5-KNH6:     Infra, <MAC 'BTHub5-KNH6' [AN8]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 39 WPA2
    BTWifi-with-FON: Infra, <MAC 'BTWifi-with-FON' [AN9]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 45
    BTWifi-with-FON: Infra, <MAC 'BTWifi-with-FON' [AN10]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 39
    *BTWifi-with-FON:Infra, <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48
    BTWiFi-with-FON: Infra, <MAC 'BTWiFi-with-FON' [AN12]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 42

  IPv4 Settings:
    Address:         10.252.215.21
    Prefix:          29 (255.255.255.248)
    Gateway:         10.252.215.17

    DNS:             192.168.22.22
    DNS:             192.168.22.23

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/canatan]] (600 root)
[connection] id=canatan | type=802-11-wireless
[802-11-wireless] ssid=canatan | mac-address=<MAC 'wlan0' [IF1]>
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/BTWifi-with-FON]] (600 root)
[connection] id=BTWifi-with-FON | type=802-11-wireless
[802-11-wireless] ssid=BTWifi-with-FON | mac-address=<MAC 'wlan0' [IF1]>
[ipv6] method=auto
[ipv4] method=auto

[[/etc/NetworkManager/system-connections/eduroam]] (600 root)
[connection] id=eduroam | type=802-11-wireless | permissions=user:fatma:;
[802-11-wireless] ssid=eduroam
[ipv4] method=auto
[ipv6] method=auto
[802-1x] ca-cert=/home/fatma/.cat_installer/ca.pem

##### iw reg get ########################

Region: Europe/London (based on set time zone)

country GB:
	(2402 - 2482 @ 40), (N/A, 20)
	(5170 - 5250 @ 40), (N/A, 20)
	(5250 - 5330 @ 40), (N/A, 20), DFS
	(5490 - 5710 @ 40), (N/A, 27), DFS
	(57240 - 65880 @ 2160), (N/A, 40), NO-OUTDOOR

##### iwlist channels ###################

lo        no frequency information.

wlan0     32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz
          Current Frequency:2.412 GHz (Channel 1)

##### iwlist scan #######################

lo        Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Device or resource busy

##### module infos ######################

[ath10k_pci]
filename:       /lib/modules/4.4.0-63-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
firmware:       ath10k/QCA9377/hw1.0/board.bin
firmware:       ath10k/QCA9377/hw1.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/board-2.bin
firmware:       ath10k/QCA6174/hw3.0/board.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-4.bin
firmware:       ath10k/QCA6174/hw2.1/board-2.bin
firmware:       ath10k/QCA6174/hw2.1/board.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-5.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-4.bin
firmware:       ath10k/QCA988X/hw2.0/board-2.bin
firmware:       ath10k/QCA988X/hw2.0/board.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-5.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-4.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-3.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-2.bin
firmware:       ath10k/QCA988X/hw2.0/firmware.bin
license:        Dual BSD/GPL
description:    Driver support for Atheros QCA988X PCIe devices
author:         Qualcomm Atheros
srcversion:     8CBDAC7980FC042032AE6A6
depends:        ath10k_core
intree:         Y
vermagic:       4.4.0-63-generic SMP mod_unload modversions 
parm:           irq_mode:0: auto, 1: legacy, 2: msi (default: 0) (uint)
parm:           reset_mode:0: auto, 1: warm only (default: 0) (uint)

[ath10k_core]
filename:       /lib/modules/4.4.0-63-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_core.ko
license:        Dual BSD/GPL
description:    Core module for QCA988X PCIe devices.
author:         Qualcomm Atheros
srcversion:     2270F04573C68C47B0DF2B4
depends:        mac80211,cfg80211,ath
intree:         Y
vermagic:       4.4.0-63-generic SMP mod_unload modversions 
parm:           debug_mask:Debugging mask (uint)
parm:           uart_print:Uart target debugging (bool)
parm:           skip_otp:Skip otp failure for calibration in testmode (bool)
parm:           cryptmode:Crypto mode: 0-hardware, 1-software (uint)
parm:           rawmode:Use raw 802.11 frame datapath (bool)

[ath]
filename:       /lib/modules/4.4.0-63-generic/kernel/drivers/net/wireless/ath/ath.ko
license:        Dual BSD/GPL
description:    Shared library for Atheros wireless LAN cards.
author:         Atheros Communications
srcversion:     3FCDBF7CE71CB8FB980D59D
depends:        cfg80211
intree:         Y
vermagic:       4.4.0-63-generic SMP mod_unload modversions 

[mac80211]
filename:       /lib/modules/4.4.0-63-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     59E6C095E163EDB3ECF327B
depends:        cfg80211
intree:         Y
vermagic:       4.4.0-63-generic SMP mod_unload modversions 
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/4.4.0-63-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     A7DC879B6551813C20004F1
depends:        
intree:         Y
vermagic:       4.4.0-63-generic SMP mod_unload modversions 
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[ath10k_pci]
irq_mode: 0
reset_mode: 0

[ath10k_core]
cryptmode: 0
debug_mask: 0
rawmode: N
skip_otp: N
uart_print: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp
rtc

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/libopenni-sensor-pointclouds0.conf]
blacklist gspca_kinect

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

rfkill block bluetooth

exit 0

##### pm-utils ##########################

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x168c:0x003e (ath10k_pci)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'wlan0' [IF1]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #############################

[ 4022.493832] wlan0: authenticate with <MAC 'BTWifi-with-FON' [AN9]>
[ 4022.549051] wlan0: send auth to <MAC 'BTWifi-with-FON' [AN9]> (try 1/3)
[ 4022.554497] wlan0: send auth to <MAC 'BTWifi-with-FON' [AN9]> (try 2/3)
[ 4022.556863] wlan0: authenticated
[ 4022.559997] wlan0: associate with <MAC 'BTWifi-with-FON' [AN9]> (try 1/3)
[ 4022.566996] wlan0: RX AssocResp from <MAC 'BTWifi-with-FON' [AN9]> (capab=0x421 status=0 aid=4)
[ 4022.569659] wlan0: associated
[ 4022.571955] ath: EEPROM regdomain: 0x833a
[ 4022.571958] ath: EEPROM indicates we should expect a country code
[ 4022.571960] ath: doing EEPROM country->regdmn map search
[ 4022.571962] ath: country maps to regdmn code: 0x37
[ 4022.571963] ath: Country alpha2 being used: GB
[ 4022.571964] ath: Regpair used: 0x37
[ 4022.571966] ath: regdomain 0x833a dynamically updated by country IE
[ 4099.571538] wlan0: deauthenticating from <MAC 'BTWifi-with-FON' [AN9]> by local choice (Reason: 3=DEAUTH_LEAVING)
[ 4104.567581] ath10k_pci 0000:02:00.0: failed to flush transmit queue (skip 0 ar-state 1): 0
[ 4148.304769] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4186.975730] wlan0: authenticate with <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]>
[ 4187.029925] wlan0: send auth to <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (try 1/3)
[ 4187.034881] wlan0: send auth to <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (try 2/3)
[ 4187.040024] wlan0: send auth to <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (try 3/3)
[ 4187.044839] wlan0: authentication with <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> timed out
[ 4187.225266] wlan0: authenticate with <MAC 'BTWifi-with-FON' [AN9]>
[ 4187.278772] wlan0: send auth to <MAC 'BTWifi-with-FON' [AN9]> (try 1/3)
[ 4187.281166] wlan0: authenticated
[ 4187.283758] wlan0: associate with <MAC 'BTWifi-with-FON' [AN9]> (try 1/3)
[ 4187.290601] wlan0: RX AssocResp from <MAC 'BTWifi-with-FON' [AN9]> (capab=0x421 status=0 aid=4)
[ 4187.293712] wlan0: associated
[ 4187.293763] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 4187.297612] ath: EEPROM regdomain: 0x833a
[ 4187.297616] ath: EEPROM indicates we should expect a country code
[ 4187.297618] ath: doing EEPROM country->regdmn map search
[ 4187.297620] ath: country maps to regdmn code: 0x37
[ 4187.297622] ath: Country alpha2 being used: GB
[ 4187.297623] ath: Regpair used: 0x37
[ 4187.297625] ath: regdomain 0x833a dynamically updated by country IE
[ 4274.832482] wlan0: authenticate with <MAC 'BTWifi-with-FON' [AN10]>
[ 4274.887142] wlan0: send auth to <MAC 'BTWifi-with-FON' [AN10]> (try 1/3)
[ 4274.892241] wlan0: send auth to <MAC 'BTWifi-with-FON' [AN10]> (try 2/3)
[ 4274.897478] wlan0: send auth to <MAC 'BTWifi-with-FON' [AN10]> (try 3/3)
[ 4274.905764] wlan0: authentication with <MAC 'BTWifi-with-FON' [AN10]> timed out
[ 4279.710803] wlan0: authenticate with <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]>
[ 4279.764791] wlan0: send auth to <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (try 1/3)
[ 4279.769934] wlan0: send auth to <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (try 2/3)
[ 4279.771527] wlan0: authenticated
[ 4279.774513] wlan0: associate with <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (try 1/3)
[ 4279.886646] wlan0: associate with <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (try 2/3)
[ 4279.891705] wlan0: RX AssocResp from <MAC 'BTWifi-with-FON:Infra, <MAC address>, Freq 2412 MHz, Rate 54 Mb/s, Strength 48' [AN11]> (capab=0x421 status=0 aid=1)
[ 4279.895153] wlan0: associated
[ 4279.897926] ath: EEPROM regdomain: 0x833a
[ 4279.897929] ath: EEPROM indicates we should expect a country code
[ 4279.897931] ath: doing EEPROM country->regdmn map search
[ 4279.897932] ath: country maps to regdmn code: 0x37
[ 4279.897933] ath: Country alpha2 being used: GB
[ 4279.897934] ath: Regpair used: 0x37
[ 4279.897936] ath: regdomain 0x833a dynamically updated by country IE

########## wireless info END ############
Tags (3)
0 Ratings
Reply
1 REPLY 1
Highlighted
Distinguished Sage
Distinguished Sage
620 Views
Message 2 of 2

Re: Ubuntu 14.04 BT Wifi FON connection issues

Looking at the signal levels and speed, I suspect you are connecting to a distant neighbours signal rather than your own and the signal is too poor to connect. You appear to be able to see 4 BT Wifi with FON signals, try the others.

0 Ratings
Reply