cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,085 Views
Message 1 of 6

Now TV app on BT TV box

Go to solution

I have a BT TV pro box and am having recurring issues streaming content from via the Now TV app. 
It generally starts fine then hits a fault after around 40-45 minutes - at this time look for what might be wrong the BT TV box has lost all apps and has lost the internet connection. I have to wait for the box to reconnect the internet and restart the apps before I can continue streaming again. This situation is repeated every 40-45 minutes when streaming Now TV. Very frustrating!

I can stream using other apps on the BT TV box such as iPlayer, Netflix, Prime etc for many hours continuously with no issues. Why is this isolated the Now TV app? Further, I can watch NOW TV on other devices with no issue so it seems to come back to the BT TV box being the culprit 

I note that other users have reported similar issues specifically when using the Now TV app  on BT TV boxes and there does not seem to be a satisfactory solution.

Is there some setting I can adjust to improve things? 

Is there an update Now Tv app?

0 Ratings
Reply
5 REPLIES 5
1,055 Views
Message 2 of 6

Re: Now TV app on BT TV box

Go to solution

This is an issue that seems to rear it's head in very off circumstances, in most cases it's fixed by simply changing the ethernet cable... 

0 Ratings
Reply
1,046 Views
Message 3 of 6

Re: Now TV app on BT TV box

Go to solution

Thanks for the reply, I’ll definitely give it a try - interesting - it’s one of the few things I haven’t tried!

847 Views
Message 4 of 6

Re: Now TV app on BT TV box

Go to solution

I’m having the exact same problem. Did a new Ethernet cable work?

0 Ratings
Reply
839 Views
Message 5 of 6

Re: Now TV app on BT TV box

Go to solution

It worked for me which is why I suggested it as a remedy. I'm guessing seeing as though the OP hasn't been back, it worked 

774 Views
Message 6 of 6

Re: Now TV app on BT TV box

Go to solution

I saw the post from NigelB72 and thought I should give an update on what happened for me.

 

First the background: I live in an old property and the Ethernet distribution implemented has evolved over the years. The Wi-Fi router is in a different room to the TV. I use Ethernet over mains system to the TV in question, parts manufactured by TP-Link. I know that it is now possible to have a reliable distributed Wi-Fi throughout the house but was trying not to go to that expense unless it proved necessary.

 

In an effort to resolve the Now TV App issue I took a step by step approach to eliminate each of the interconnection points in the route. I had different cables available so it just took time. I even replaced a mains wall socket in an effort to solve this.  Each time trying out the App to determine if the issue had been resolved. This was frustrating as after each step I had to leave the system until the App had been in operation for a few hours to determine if it had been resolved. The whole process took a good few weeks – much to the annoyance of my wife, who asked  ‘why do we not get somebody (who knows what they are doing) to come and fix this properly?’

 

Throughout this process it was still only the Now Tv App that was causing a problem – and only then after streaming for approx 45mins.

 

The only cable connection I hadn’t replaced was the mains routing in the walls and the problem still hadn’t been resolved.

 

I was using high speed TPLink Rx/Tx, rated up to 500mbs. I had an older TPLink RX/TX, rated at 200mbs so I changed them out to see if using a slower transmission rate would stop the dropout.

 

 Hey Presto – problem resolved!

 

I have now been running the slower TPLink ‘internet over mains’, 200mbs for at least 3 months without a single dropout.

 

If this hadn’t worked my next step was to ditch the ‘Ethernet over mains’ and go to the full distributed Wi-Fi.

 

 

I know what worked, I could have got them faster if  I had changed the TPLink parts earlier – hindsight is a great skill!

 

Luck!

 

In conclusion I  know what worked for me but can’t explain why! I believe there is something different in the way that Now TV App operates with the BT TV box, whether it is the speed, packet structure or some more obscure software issue we will never know but why the dropout only shows up on that one App is mightily frustrating.  A question for BT but I doubt we will get a satisfactory answer.

 

Good luck in solving your own system problem!

 

Cheers