cancel
Showing results for 
Search instead for 
Did you mean: 
6,506 Views
Message 1 of 3

BTinternet IMAP Settings for MS Outlook, Mozilla Thunderbird, don't work - here's the solution

Hi All,

after spending 24 frustrating hours not getting my new laptop to set up e-mail automatically.  I see many others have had exactly the same problems and have given up.  So, doing BT's work for them, I finally found a solution.

The IMAP settings for btinternet, i.e. mail.btinternet.com do not work!

What does work is the following:

Incoming Mail (IMAP) Server

  • Server - imap.mail.yahoo.com  (instead of mail.btinternet.com)
  • Port - 993
  • Requires SSL - Yes

Outgoing Mail (SMTP) Server

  • Server - smtp.mail.yahoo.com (instead of mail.btinternet.com)
  • Port - 465 or 587
  • Requires SSL - Yes
  • Requires authentication - Yes

Your login info

  • Email address - Your full email address (name@domain.com)
  • Password - Your account's password
  • Requires authentication - Yes

Hope this helps everyone who's been having the same issues as me!

007_McHaggis... 😉

0 Ratings
Reply
2 REPLIES 2
Distinguished Sage
Distinguished Sage
6,499 Views
Message 2 of 3

Re: BTinternet IMAP Settings for MS Outlook, Mozilla Thunderbird, don't work - here's the solution

The above is a well known work around that gets posted on the forum on almost a daily basis. It will only work if you have a BTYahoo email account and not a BTMail email account.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
6,487 Views
Message 3 of 3

Re: BTinternet IMAP Settings for MS Outlook, Mozilla Thunderbird, don't work - here's the solution


@007_McHaggis wrote:

Hi All,

after spending 24 frustrating hours not getting my new laptop to set up e-mail automatically.  I see many others have had exactly the same problems and have given up.  So, doing BT's work for them, I finally found a solution.

The IMAP settings for btinternet, i.e. mail.btinternet.com do not work! Yes they do, I am using them, as are many others. Under fault conditions they may stop working for individual cases.

What does work is the following:

Incoming Mail (IMAP) Server

  • Server - imap.mail.yahoo.com  (instead of mail.btinternet.com)
  • Port - 993
  • Requires SSL - Yes

Outgoing Mail (SMTP) Server

  • Server - smtp.mail.yahoo.com (instead of mail.btinternet.com)
  • Port - 465 or 587
  • Requires SSL - Yes
  • Requires authentication - Yes

Your login info

  • Email address - Your full email address (name@domain.com)
  • Password - Your account's password
  • Requires authentication - Yes

Hope this helps everyone who's been having the same issues as me!

007_McHaggis... 😉


Just be careful if using those settings permanently. If you don't log in to webmail at least once every 90 days your account may be deleted as you will not have registered as having logged into the BT servers.