cancel
Showing results for 
Search instead for 
Did you mean: 
PeterMartinez
Contributor
487 Views
Message 1 of 18

Email messages beng sent to the wrong "local-part" of a domain

I run a group at groups.io.  Messages to the whole group are to be sent to <mygroup@groups.io> and messages to the group owner are to be sent to <mygroup+owner@groups.io.  The problem is that emails sent from btinternet addresses to the +owner local-part get wrongly sent to the whole group.  Tracing the headers in the affected emails shows clearly that the message was sent correctly by the sender but arrives at the groups.io domain with the "+owner" bit missing.  This problem affects all the group members who have email addresses @btinternet.   It doesn't affect others.

My attention has been drawn to RFC2821 which says that intermediate hosts shouldn't mess with the local parts of email addresses, but this seems to be happening here.  It looks like an intermediate host thinks that the + marks the end of the local-part, and truncates it.   It might be happening at synchronoss (a BT subcontractor?).  Has anyone else experienced problems like this?  How do I report this problem to the appropriate place where it can be investigated and fixed?  Groups.io (understandably) say it's not their problem.

Regards

Peter

0 Ratings
Reply
17 REPLIES 17
Distinguished Sage
Distinguished Sage
477 Views
Message 2 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

As an experiment, could you verify if it occurs only when using webmail to send or also if a mail client is used. If possible a test from all 4 permutations would be useful, i.e webmail from BTYahoo, client from BTYahoo, webmail from BTMail and client from BTMail.

0 Ratings
Reply
PeterMartinez
Contributor
462 Views
Message 3 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

Liquorice:

Thanks for your reply.  I only have BTYahoo available here.   The fault occurs when using an Email client and I have checked from the headers in the email that arrives at the wrong destination that it is sent correctly from the email client and arrives wrong at the wrong destination.  I just checked via BTYahoo Webmail and the fault did NOT occur.  I think that supports my hypothesis that the bug is either in the SMTP server or maybe  one hop further along the route.

I will try to find a BTMail member of my group to try the other two combinations, unless there is a BTMail member of another groups.io group reading this who can do it?

Regards

Peter

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
460 Views
Message 4 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

Interesting, I was rather expecting the opposite in that the problem would be with webmail. I will ask if the mods can investigate with the mail team, however, it would be useful to know if the problem is confined to BTYahoo clients only to assist in the investigation.

0 Ratings
Reply
Highlighted
Moderator
Moderator
427 Views
Message 5 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

Hi @PeterMartinez,

This is very interesting, especially since it works fine through webmail.

What email clients have you tried? Also, what SMTP settings do your users enter?

Make sure they match the ones at What are the settings for outgoing and incoming BT Email servers?

Thanks

DanielS

0 Ratings
Reply
PeterMartinez
Contributor
405 Views
Message 6 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

Further to my last, I just tried sending an email to the "groupname+owner" address but instead of using the SMTP server at mail.btinternet.com, I used the SMTP server at Yahoo.  I think this route is not encouraged by BT (I think they are withdrawing it soon) but it might be useful to note that it was NOT misrouted.  This may help to further localise the point in the transport process which is causing emails to addresses with a + in the "local part" (the bit before the @) to be truncated and misrouted as I described in my first post in this thread.

regards

Peter

0 Ratings
Reply
PeterMartinez
Contributor
370 Views
Message 7 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

I now know that sending a message to <mygroup+owner@groups.io> via BTMail with an email client (i.e. via SMTP) also results in the message arriving at <mygroups@groups.io> but sent via the BTMail Webmail interface it is routed correctly.

I am discussing this one on the groups.io Group Managers Forum, and a poster there has seen the appended two header lines in a misrouted message.  This shows clearly where the email address local part "ta-members+owner" has been truncated to "ta-members" either by btinternet.com or by synchronoss.net.  Look at the "for" tokens.  The full details can be seen at..

https://groups.io/g/GroupManagersForum/message/18774

...which is a publicly accessible web age so I think I am permitted to copy it here.

Regards

Peter

Received: from re-prd-rgout-002.btmx-prd.synchronoss.net ([10.2.54.5]) by re-prd-fep 041.btinternet.comwith ESMTP id <20190904180319.WRUD7208.re-prd-fep-041.btinternet.com@...> for <ta-members@groups.io>; Wed, 4 Sep 2019 19:03:19 +0100

Received: from [redacted]-imac.home ([redacted) by re-prd-rgout-002.btmx-prd.synchronoss.net (5.8.337) (authenticated as [redacted]@btinternet.com) id 5D6FA3290010097D for ta-members+owner@groups.io; Wed, 4 Sep 2019 19:03:19 +0100

0 Ratings
Reply
PeterMartinez
Contributor
344 Views
Message 8 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

DanielS:

Forgive me for not responding to your post, but I believe that we have now established that this problem occurs along the email transport route and will be present regardless of which email client is in use by the sender, and the SMTP settings in his/her email client will not be relevant (at least so long as the mail.btinternet.com SMTP server is used).   Can you now raise this problem with the Mail Team please?

Regards

Peter 

0 Ratings
Reply
Moderator
Moderator
328 Views
Message 9 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

Hi @PeterMartinez  I've sent you a Private Message with details on how you can get in contact with the mod team and we'll ask our email experts to take a look.

0 Ratings
Reply
PeterMartinez
Contributor
289 Views
Message 10 of 18

Re: Email messages beng sent to the wrong "local-part" of a domain

NeilO:

I received your private message and replied with the requested information but I have received nothing in reply, either from you or the moderators or from your email team. Even a "Thank you we are looking at it" message would be nice.

regards

Peter

 

0 Ratings
Reply