cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
655 Views
Message 1 of 9

Login email autofill disabled

Go to solution

When I login to BT email it used to present for the login email address field a drop-down box where I could select the user email. The dropdown has recently stopped appearing.

Inspecting the field I find autocomplete="off". Whilst in inspect mode, changing autocomplete="off" to autocomplete="username" temporarily restores the dropdown function.

Please could the code be repaired so as not to disable autofill?

0 Ratings
Reply
8 REPLIES 8
643 Views
Message 2 of 9

Re: Login email autofill disabled

Go to solution

If this is happening where you first log onto your BTMail, the login auto complete is a function of your browser not a BT function. 

You should go into your browser's settings and check that the "Passwords" function is turned on.

630 Views
Message 3 of 9

Re: Login email autofill disabled

Go to solution

Also check that BT.com is not listed under 'Never Saved Passwords'


A thank you is nice, it makes the effort worthwhile, but a kudo is better, by a country mile. (I'm no poet & boy don't I know it)
0 Ratings
Reply
601 Views
Message 4 of 9

Re: Login email autofill disabled

Go to solution

Thank you very much, gg30340 and Les-Gibson for your suggestions which have helped me forward with this.

Offer to save passwords is on.

BT.com has been removed from 'Never Saved Passwords'.

Those suggestions allow the saved passwords feature, which is similar but not identical to autocomplete. The user wishes the email address to autocomplete, but does not want the password remembered. A workaround using saved passwords (as suggested) is to save a single character in place of the password. Unfortunately I could not save an empty password.

The login auto complete function of the browser is working fine for other sites including https://community.bt.com/ where I am offered a dropdown with my username.

The login auto complete function of the browser is inhibited for https://home.bt.com/login/loginform which serves the page with input tag option autocomplete="off". The browser respects that input tag by not offering autofill. The inhibition of autofill can be prevented by a browser extensions that changes autocomplete="off" to autocomplete="on". See
https://superuser.com/questions/1231998/how-to-turn-off-autocomplete-off
https://chrome.google.com/webstore/detail/force-autocomplete/piechbhjioolbecaioglhamjjjkmbchj?hl=en
https://chrome.google.com/webstore/detail/always-autocomplete/djcfppnajkeijjkplclmeiddkefeaiel?hl=en
Those Chrome extensions do enable autocomplete for BT email login, as desired. I have not yet found equivalent disablers of autocomplete="off" for other browsers.

0 Ratings
Reply
594 Views
Message 5 of 9

Re: Login email autofill disabled

Go to solution

One other suggestion you may be interested in trying and is simple to implement.

You can edit the saved passwords in your browser, if you don't want the whole password remembered then you could delete a number of characters from it and save it, what remains would then serve as a hint should you forget it but would not allow the user to login without first manually entering the missing characters.

 


A thank you is nice, it makes the effort worthwhile, but a kudo is better, by a country mile. (I'm no poet & boy don't I know it)
0 Ratings
Reply
583 Views
Message 6 of 9

Re: Login email autofill disabled

Go to solution

Presumably you have tried clearing all the history and cookies from the browser.

0 Ratings
Reply
559 Views
Message 7 of 9

Re: Login email autofill disabled

Go to solution

Re gg30340 on ‎17-07-2022 13h20, thank you, I cleared all the history and cookies from MicroSoft Edge browser and retried. The behaviour was as previously reported. The browser correctly respects the downloaded autocomplete="off" and does not offer autofill.

Re Les-Gibson on ‎17-07-2022 11h44, thank you, that is pretty much the workaround that I described at ‎17-07-2022 11h06.

I previous mentioned extensions for Chrome that enable autocomplete for BT email login, as desired.
For Opera there is Autocomplete Control https://addons.opera.com/en-gb/extensions/details/autocomplete-control/
For Firefox there is Autocomplete Control https://addons.mozilla.org/en-GB/firefox/addon/autocomplete-control/

So I now appear to have the desired autofill in Chrome, Opera and Firefox browsers.

It would be interesting to know how we can get the equivalent functionality to override autocomplete="off" in Edge, Safari and other browsers.

0 Ratings
Reply
556 Views
Message 8 of 9

Re: Login email autofill disabled

Go to solution

As previously stated, it would appear to be a problem with your browser/device.

I use Edge, Chrome ,Opera and Firefox using the browsers own password storage function without any extra add on to store the logon/password without any problems.

Do you have any Antivirus/security add ons that may be stopping the browsers autofill function from working. 

0 Ratings
Reply
537 Views
Message 9 of 9

Re: Login email autofill disabled

Go to solution

I too can use the browsers own password storage function without any extra add on to store the logon/password without any problems. Also, the browsers' autofill function is working correctly and is not being stopped by Antivirus/security add ons. The autofill function is being inhibited by the browsers correctly respecting the autocomplete="off" request that is nowadays served by https://home.bt.com/login/loginform. The autofill function is active when the browsers correctly respect the autocomplete="on" request that is substituted by the extensions.

For me the issue is now solved, as it is sufficient to have the functionality in Chrome, Opera and Firefox, and I don't currently need to provide it in the other browsers. I just thought that for someone later picking up this thread, workarounds for other browsers could be useful.

Thanks again for your advice.

0 Ratings
Reply