cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
546 Views
Message 1 of 6

Lost emails from trusted senders sent on Reply are not being received

Go to solution

I am not receiving emails from trusted senders if they use Reply to an email I sent them.

0 Ratings
Reply
5 REPLIES 5
533 Views
Message 2 of 6

Re: Lost emails from trusted senders sent on Reply are not being received

Go to solution

Check that you have not added them to your blocked senders list.

Log onto your BTMail account using a browser, not an email client/app, and then click on your username at the right hand side. Select "Settings" then go to the left hand side and select "Mail". Scroll down and click on "Blocked Senders". Scroll down the list until you find the one you want to unblock and select it. Click on "delete".

0 Ratings
Reply
527 Views
Message 3 of 6

Re: Lost emails from trusted senders sent on Reply are not being received

Go to solution
Tried this, but the senders aren't blocked.
0 Ratings
Reply
501 Views
Message 4 of 6

Re: Lost emails from trusted senders sent on Reply are not being received

Go to solution

Did you check that the senders domain, the part after @,was not in your blocked list?

0 Ratings
Reply
478 Views
Message 5 of 6

Re: Lost emails from trusted senders sent on Reply are not being received

Go to solution

Hadn't tried that, and thank you for the suggestion.  Now that I look, the people I am not receiving emails from are on gmail.  And some of the blocked senders are on gmail too.  Could this be the problem?

 

Also, I have received an email purportedly from BT, but really from  a  (edited by mod)@hotmail.co.uk, telling me that 10 emails have been blocked and giving a link for me to unblock them.  Of course I haven't used that link.  Could this indicated some problem with phishing or being hacked?

0 Ratings
Reply
471 Views
Message 6 of 6

Re: Lost emails from trusted senders sent on Reply are not being received

Go to solution

Please remove the email address from your post as it is against forum rules to post email addresses.

Yes it is most likely that you have blocked the gmail domain and yes I would say that it is a phishing email. 

0 Ratings
Reply