cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gypsophila
Aspiring Contributor
214 Views
Message 1 of 7

Mail coming in to wrong inbox

Hi, hoping someone can help.  I have several bt addresses and just lately my incoming mail  on one account is going into the wrong inbox.  I've checked settings - auto forwarding, rules etc but all ok.  Don't understand why it's going to the wrong address. Any ideas?

0 Ratings
Reply
6 REPLIES 6
NeilO
Moderator
Moderator
183 Views
Message 2 of 7

Re: Mail coming in to wrong inbox

Hi, @gypsophila Thanks for posting and welcome back to the community. How do you view your email inboxes, are you using webmail or an email client like outlook or an email app?

Thanks

Neil

0 Ratings
Reply
gypsophila
Aspiring Contributor
165 Views
Message 3 of 7

Re: Mail coming in to wrong inbox

Hi Neil, thanks for responding.  I'm using webmail on a pc.

0 Ratings
Reply
NeilO
Moderator
Moderator
158 Views
Message 4 of 7

Re: Mail coming in to wrong inbox

Hi @gypsophila no problem. When you log in to www.bt.com/email then click on your email in the top right of the webpage, choose settings then accounts, do you have more than one email address listed there?

Thanks

Neil 

0 Ratings
Reply
gypsophila
Aspiring Contributor
147 Views
Message 5 of 7

Re: Mail coming in to wrong inbox

maybe I should have mentioned I'm using BT Premium mail.  When I log in I'm directed to my 'favourite' address and from there I can use the drop down menu to 'switch accounts' which shows all of my addresses.  (I'm off to work shortly so please forgive me if there's a delay in my replies.)

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
143 Views
Message 6 of 7

Re: Mail coming in to wrong inbox

Premium mail is no different to standard mail, it is just the paid for version.

If you log in to each account individually here do you get the right mail in the right inbox?

0 Ratings
Reply
gypsophila
Aspiring Contributor
93 Views
Message 7 of 7

Re: Mail coming in to wrong inbox

Thanks for your help.  Yes, it seems all correct when I log in individually.

0 Ratings
Reply