cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
joannasa
Contributor
3,351 Views
Message 1 of 20

New email format - spam filter stopped working

BT recently updated my email format and it looks like we can't go back to the original.

With this update it seems to have totally deleted all previous requests I had marked as spam and my spam filter no longer seems to be working.  Can anyone advise if there is anyway around this apart from creating a new email address?

0 Ratings
Reply
19 REPLIES 19
gg30340
Distinguished Sage
Distinguished Sage
3,333 Views
Message 2 of 20

Re: New email format - spam filter stopped working

Because you are on a completely different email system the new spam filters need to learn what and what is not spam.

This can take time but if you mark emails in your inbox that are spam as "spam" and those that are not spam that have ended up in your spam folder as "not spam" the spam filters will learn.

If you find that a person that you consider as "safe"  whose emails always end up in your spam folder you can add them to your "safe senders" list. You can find that in the settings found by clicking on your username at the top right. Once in the settings click on "Mail" then go to "Safe Senders" and add the address then click save. 

joannasa
Contributor
3,325 Views
Message 3 of 20

Re: New email format - spam filter stopped working

Thanks.

0 Ratings
Reply
joannasa
Contributor
3,282 Views
Message 4 of 20

Spam filter totally not working - nothing going into spam

Since BT informed me my email system had been updated my spam filter has totally stopped working.  Not only am I receiving around 30 junk emails a day, even if I mark them as spam or move to the spam folder, these very same emails will appear a few days later.

In fact nothing is being directed into my spam box at all.  It is really frustrating.  I called BT and all they could suggest was try another browser of choose move to spam rather than mark as.  It is particularly annoying as I didn't have this problem at all before the update.  Has anyone else had this problem?  I will be posting a letter to them soon as this seems to be the only way that I can guarantee someone will look into the issue.

 

 

0 Ratings
Reply
Hugh3lf
Beginner
3,242 Views
Message 5 of 20

Re: Spam filter totally not working - nothing going into spam

Yes I have the same problem, and again it occurred after BT and Yahoo divorced.  Like you, nothing goes into my Spam folders ( despite the fact I now have two of them for some reason).  Despite marking stuff as Spam, the system never learns, and I still get stuff from the same sender in my inbox.  The old BTYahoo Spam system worked well, what has happened BT?

0 Ratings
Reply
howardscorton
Aspiring Contributor
3,215 Views
Message 6 of 20

Re: New email format - spam filter stopped working

Same here - it's as if spam filter does not exist, all spam arriving in inbox. How do you mark it as spam now?

0 Ratings
Reply
howardscorton
Aspiring Contributor
3,212 Views
Message 7 of 20

Re: New email format - spam filter stopped working

How do you mark it as spam now?
0 Ratings
Reply
joannasa
Contributor
3,183 Views
Message 8 of 20

Re: New email format - spam filter stopped working

I think I'm finally getting it solved.  It's to do with the upgrade and a problem with the synchronisation.  I called up and it was passed to second line support who asked a few questions then put in a request to resynch the folders again.  If you call them up they should be able to fix for you.

0 Ratings
Reply
gg30340
Distinguished Sage
Distinguished Sage
3,177 Views
Message 9 of 20

Re: New email format - spam filter stopped working

Call me cynical but I think you have been given a load of flannel but I'm willing to be proved wrong so please keep the thread updated with what happens after BT "resynch the folders again".

howardscorton
Aspiring Contributor
3,139 Views
Message 10 of 20

Re: New email format - spam filter stopped working

Well, yes, that's the theory but after 3 weeks of marking as spam still nothing is going to the spam folder, everything arrives into my inbox. The system is supposed to "learn" but it isn't.