cancel
Showing results for 
Search instead for 
Did you mean: 
Suzie_J
Newbie
5,996 Views
Message 1 of 3

Problem sending emails on a MacBook using a new BT hub

Can anyone help? I am using a Mac Mail on a MacBook running 10.6.8. We received a new hub from BT and I am no longer able to send emails from my email account using the hub. Wireless connections other than my own home hub work just fine, so I know there is a problem using the home hub.
As you can imagine this is VERY frustrating. I have paid a technical support person £50 to look into this and we have no answers. I have spent an hour on the phone to BT help and got nowhere either. They could not understand that I was running Mail on a Mac and gave me instructions to diagnose the problem that were for PC users. They could not put me through to Mac specific help.
I have read through lots of varied forum posts and have found out that it seems simply that BT hubs do not seem to like Apple products. My email is provided by 123-reg and I am using their webmail to send emails but am not happy to do this on a long term basis. I work both from home and elsewhere and am not a technical person so need a practical and straightforward answer to this problem. I am paying BT each month to use the hub and if I cannot I would like to stop paying asap.

Can anyone help?

0 Ratings
Reply
2 REPLIES 2
Highlighted
Aratark
Contributor
5,992 Views
Message 2 of 3

Re: Problem sending emails on a MacBook using a new BT hub

Have you just moved to the Home Hub 3 or 4 after being on the Hub 2?  If so, I can provide a resolution for you.

 

The issue is with the way the mac presents it's name to the router, it doesn't resolve properly on the router and as a result causes issues with email providers that use SSL.

 

The easiest way to check if this is the issue is to go to the apple menu>system preferences>network.  Select wireless on the left hand side, then advanced in the bottom right corner.  Select DNS at the top of this screen.  Then press the + symbol in the bottom left corner and then type 8.8.8.8.  Hit apply, then close the network prederences box.  This will probably ask you to save the changes.  Hit save, or apply changes.

 

Open mac mail and try and send a new email, should go fine.

 

Now we have determined the issue, the fix is quick, but a couple of steps.  Go to spotlight in the top right corner of your screen and type terminal, select it from the list.  This will bring up a little screen where you can enter type written commands.  You need to type scutil --set HostName DavesImac  (for example).  then close terminal.

 

Next step is to go back to apple menu>system preferences>sharing.  At the top of this screen it shows the name of your mac.  There is an edit button, hit that and then in the box on the next screen type in the same name as you typed on terminal (DavesImac in our example), then hit apply.

 

Go back to system preferences, then select network.  Select wireless again and at the top it shows location.  Click on the up down arrow and then hit the + button and enter a new location, home for example, then select it.  Hit apply at the bottom of the screen.  Then hit advanced again and at the top select tcp/ip.  There should be a button on here Refresh DHCP lease.  Hit that and it will refresh your connection to the router.  CLose down all the screens, reopen mac mail and try and send an email, should go fine.

 

A

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
5,991 Views
Message 3 of 3

Re: Problem sending emails on a MacBook using a new BT hub

When you say you received a new hub from BT does that mean you were previously using an older homehub without problem or are you a new customer to BT.

 

If you are a new customer have you set up your email as per this guide.

 

http://bt.custhelp.com/app/answers/detail/a_id/9960/~/setting-up-bt-yahoo!-mail-on-mail-for-mac-osx

 

If you are usig a non BT email address you may have to verify your email, see this link

 

http://bt.custhelp.com/app/answers/detail/a_id/10903/~/how-to-verify-email-addresses-(to-avoid-getti...

0 Ratings
Reply