cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newbie
975 Views
Message 1 of 5

Problem with sending emails

I have had a problem sending emails that has occurred since this morning, early hours of 2020 in fact, in both my iPhone and iPad. I get an error message that says "cannot send mail - the sender address was invalid". I can see others have previously had this problem, I have gone through the steps they have suggested, including looking at the SMTP settings, I've tried re-entering my email address and password, all to no avail. Has anyone else had this problem, or even better,know what I need to do to fix it? Thanks.

0 Ratings
Reply
4 REPLIES 4
Highlighted
Distinguished Sage
Distinguished Sage
957 Views
Message 2 of 5

Re: Problem with sending emails

It is a BT server problem which has been going on for some time and the best advice when it happens is to do nothing, especially do not change passwords or delete the account from your phone as that can cause more problems than it solves.

The first thing to do when it happens is check to see if you can log on to your email account via a web browser. If you can there is obviously nothing wrong with your password or account hence the advice to do nothing.

If the problem did not resolve its self after a day or two or in your instance where you have deleted the email account from your device you should stop your iPhone and any other devices from checking for email.

Once you have done that, change your email password and check that you can access your email via webmail (on a browser).

If that works you should wait at least 30 minutes to an hour and then add the new password to your iPhone and again check it works. If it does then move onto the next device.

If the above does not resolve the problem, when you change your BT password on an iPhone/iPad/Apple device it may only change for INCOMING mail.

To change the outgoing mail password you have to go into Settings; then scroll down to Mail, Contacts, Calendars. From there select the BT email account and select the account where it is listed under IMAP.

You will find the details for the account and can change the password for the Incoming server there, the outgoing mail server only shows SMTP and mail.btinternet.com You have to tap on that Primary Server in order to find where the Outgoing password is hidden so you can update it.

When setting up the email account on your device you are best to set it up manually, using "other" and ensure that you are using the correct settings as per this link.

https://www.bt.com/help/email/manage-email-account/manual-settings/what-are-the-settings-for-outgoin...

0 Ratings
Reply
Highlighted
Newbie
948 Views
Message 3 of 5

Re: Problem with sending emails

Thanks for the response. Since posting I’ve been outside the building and to another place and WiFi system. One of the test emails I had tried to send which was on my phone then got delivered - I’m on WiFi as I’m abroad - so it looks like the problem may lie with the WiFi network at the hotel I’m in. Interesting that it only started after midnight on 31 December 2019!
i will do as you suggest and wait and see if the problem goes away. But thanks again for the advice.

0 Ratings
Reply
Highlighted
Distinguished Sage
Distinguished Sage
943 Views
Message 4 of 5

Re: Problem with sending emails

Had you said you were not in the UK the advice would have included that it is probably the ISP that you are using that is the problem and not your email apps on your devices.

If it is working using a different ISP then I would leave things as they are and make no changes.

0 Ratings
Reply
Highlighted
Newbie
386 Views
Message 5 of 5

Re: Problem with sending emails

I have had the same problem suddenly occurred and it has now lasted several days. I can log into the web account ok. But in outlook and on my iphone i can receive emails but not send them. I have tried changing the password but same thing is continuing. In the past it has happened but usually within a day or two it resolves but this time it is not resolving. 

0 Ratings
Reply