cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
315 Views
Message 11 of 15

Re: Spam filter not working

Just following this thread I see that I am not alone in experiencing this problem.  4 months ago we suddenly started receiving spam emails on one of our addressess - one which is only used for friends and some local organisations.  As an ex IT person I always access our emails first on BT's server and so set up rules as well marking these emails as spam - yet still they arrive direct into the inbox - on some days over 20.  The farce is that almost all the senders have what appears to be an eastern European (or further east) name; the subjects almost always contain the words 'sex', 'dating', 'photos'  in many cases are actually in some foreign script and in some cases are just gobbledygook!!  Despite doing everything BT advise me to do they still keep coming direct into the inbox.  I understand the issues arising due to the sheer volume of spam but, certainly in our case, there is nothing remotely 'normal' about any of the emails which we receive yet they keep coming.

238 Views
Message 12 of 15

Re: Spam filter not working

The reply that the majority of spam is blocked is, in my case, absolute nonsense.  Over a 4 month period my wife's email address (only used by a few freinds) was inundated with up to 30 obviously sexual emails and ALL from abroad, often in mid-Eiropean or Far eastern script.  I marked every email throughout this period as Spam but they still kept going direct to her Inbox with the very occasional one going to Spam.  It was so bad we had to change her address.  Now the same thing is happening with my main address - these are either all foreign and blatently sexual or some spurious site saying that I have won something.  Everyone marked as Spam but still they come.  A simple option for people like me would to be able to block anything in a foreign language i.e. non English but this does not seem possible.  After being with BT for ever I think it may be time to change!

0 Ratings
Reply
236 Views
Message 13 of 15

Re: Spam filter not working

May sound a reasonable solution if you know how to write the script!!!  Again, this is a BT issue and I doubt that they care.

0 Ratings
Reply
213 Views
Message 14 of 15

Re: Spam filter not working


@sam63wrote:

Just following this thread I see that I am not alone in experiencing this problem.  4 months ago we suddenly started receiving spam emails on one of our addressess - one which is only used for friends and some local organisations. 


The issue could well be down to your contacts themselves being compromised in some way, and hence your email address is collateral damage by no fault of your own.

Marking them as spam can take time, and simply blocking the email address "sender" won't work.

There will be potentially 1000s of spam emails blocked before getting anywhere near anyone's account due to the anti-spam systems. Of course, getting 10s a day looks like the system isn't working for you personally.

0 Ratings
Reply
54 Views
Message 15 of 15

Re: Spam filter not working

Well, I've started getting a lot more of these again the past few days, particularly from domains ending .cfd and .sbs

Looks like I'm going to have a write a few more rules myself to block these to supplement BT's spam filters!

 

0 Ratings
Reply