cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
706 Views
Message 1 of 22

email login on bt.com homepage

Hi Sean & Co,

Please pass on the news that the email 'button' on the bt.com homepage (top right corner) has failed. I had to use Google to find the login screen and by-pass this screen.

Sorry can't include screenshot as it includes HTML

 

 

 

 

 

 

 

21 REPLIES 21
Highlighted
Distinguished Sage
Distinguished Sage
699 Views
Message 2 of 22

Re: email login on bt.com homepage

It would not appear to be a general fault.

Does the email button at the top of this page work for you?

Try clearing the history and cookies from your browser.

0 Ratings
Reply
Highlighted
Contributor
687 Views
Message 3 of 22

Re: email login on bt.com homepage

Hi. Not tried deleting history & cookies yet. Same issue yesterday different PC , was then trying to get to a different (secondary) email address and again this am. In both cases rest of internet appears OK and 'wrong clicking' email button opens window to include reload [used/ tried that]. Use term 'wrong click', as 1 PC set for a LH person
0 Ratings
Reply
Highlighted
Moderator
Moderator
681 Views
Message 4 of 22

Re: email login on bt.com homepage

Hi @CanalDigger,

Thanks for bringing this to our attention. 

As @gg30340 has mentioned this doesn't seem to be a general fault. I have tested on 3 devices and it loads fine for me.

Is anyone else experiencing the same issue?

Thanks

Matt

0 Ratings
Reply
Highlighted
Aspiring Expert
664 Views
Message 5 of 22

Re: email login on bt.com homepage

Certainly had some similar issues yesterday 18th, at one point nothing on the bt.com home page was working on google chrome browsers. I tried incognito mode to rule out extension issues then switched to trying a couple (vivaldi, opera) of other browsers where it also failed as well and then it seemed to eventually come back ok. I just assumed it was BT making front end changes and reloading was problematic. (The BT.COM screen did seem to change but again not sure how or why as usually only use it to get to eMail.

I was going to flag this up but as it righted itself felt it was bad enough nothing ever getting fixed in the BTeMail system so probably wasn't worth it to mention it. 

When it was not working the menu items on bt.com page did not work (No underlines or actions etc). In fact at one point in chrome (Latest version) nothing on the bt.com page worked. As the op says all other sites were working ok on all browsers tested. Has not seemed to be an issue since or today though.

Highlighted
Beginner
622 Views
Message 6 of 22

Re: email login on bt.com homepage

Also nothing in the blue header on the bt.com homepage works for me. Can access my account and emails by googling but only the "Ad" one works and on the original page can log in further down the page - but it just disappears into the ether when pressing enter. 

0 Ratings
Reply
Highlighted
Aspiring Expert
609 Views
Message 7 of 22

Re: email login on bt.com homepage

Its broken at the moment on some browsers, vivaldi, chrome, edge you name it if one types bt.com it seems to point to 

https://www.bt.com/?

which is broken but looks like the normal bt screen but is not completing and subsequently not reacting correctly none of the links work at present as op have commented

Does seem to work on firefox

Some browsers seem to convert bt.com to bt.com/ but not always.

@Matt-S this seems to be perhaps a server/instance that is not converting bt.com correctly just a thought. Firefox seems to work this time but not sure if its a local broswer conversion/ storage issue. Failing on a lot of browsers though.

0 Ratings
Reply
Highlighted
Distinguished Sage
Distinguished Sage
602 Views
Message 8 of 22

Re: email login on bt.com homepage

Using the link you have posted, all the buttons/links work fine for me and Chrome, Opera, Edge and Firefox as does typing bt.com.

0 Ratings
Reply
Highlighted
Aspiring Expert
591 Views
Message 9 of 22

Re: email login on bt.com homepage

Bit odd that it still does not not work on 2 machines now using chrome bt.com entered into my laptop running windows 10 as opposed to my day time machine running windows 7 (Shouldn't be an issue anyway) If I use edge its okay and converts to www.bt.com correctly but chrome on the w10 laptop immediately converts to bt.com/? and the screen does not complete. Both machine are running most recent chrome.

I cleared all the cookies for bt.com on the w7 machine but still it will not convert correctly to get a correct screen. I'm flummoxed thankfully I have a backup in my bookmarks links.

For ref chrome is Version 85.0.4183.102 (Official Build) (64-bit)

Also just got the wife upstairs to try her laptop using chrome and it fails on there too.

She typed in bt.com and no links worked on the expected screen, before did her system came up with bt.com/email as she was typing so I go her to remove that back to bt.com. Thing is with /email in the link it worked ok with the email link underlined the links were active. As I say just using bt.com it seems to me the routing is not working correctly but not at our end.

So I reiterate using bt.com does not work currently on all of our machines. We are in trowbridge, wiltshire if it helps in case we are being routed by different servers to those that do work.

I tried also using google search for bt.com and it came up correctly - i thought but it might fail and it did. I wonder if i were to change my ip address it might actually fix it. perhaps there are groups of servers across the country that are not being updated all at the same time when bt makes changes to the front pages. 

bt.com/email does seem to give a usable page where the email link works still looks a bit odd when clicking it and getting the login on a white background but it does work when bt.com does not.

0 Ratings
Reply
Highlighted
Beginner
531 Views
Message 10 of 22

Re: email login on bt.com homepage

I am still having this issue using both Edge or Firefox on my Windows 10 PC. The page worked for a brief time on Saturday but has returned with the email button and other header buttons not working on the homepage.

0 Ratings
Reply