cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
GillE
Beginner
501 Views
Message 1 of 5

Master socket works, even new faceplate does not

Go to solution

Hi - hoping someone can help - we've just moved into a new house and the phone works through the test socket in the master socket fine, but will not work through the faceplate. BT's help suggested this was a fault of the equipment, so I bought a new master socket and tried the faceplate supplied with that and I still can't get a dial tone through the new faceplate. It's a double socket and I will need it for 'broadband' internet as well.

Is there something daft I'm missing?

GillE_0-1616600210640.jpeg

 

0 Ratings
Reply
4 REPLIES 4
imjolly
Distinguished Sage
Distinguished Sage
488 Views
Message 2 of 5

Re: Master socket works, even new faceplate does not

Go to solution

did the new master socket come complete with a new backplate?  if so you could try replacing existing backplate and reconnecting incoming cable to terminals A&B on back of backplate and see if that works



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
Starwire
Recognised Expert
474 Views
Message 3 of 5

Re: Master socket works, even new faceplate does not

Go to solution

Chances are the backplate is a screwed to tightly to the flush mounted back box.

Common issue with NTE5c’s. Try loosening the two backplate screws and then putting the front plate on to see if it works.

Devon_Dave
Distinguished Guru
465 Views
Message 4 of 5

Re: Master socket works, even new faceplate does not

Go to solution

Is there any wiring attached to the front plate? 

(If I have helped you in any way please click the thumbs up. Thank You)
If I have solved your Issue please click the "Mark as accepted solution" button.
GillE
Beginner
430 Views
Message 5 of 5

Re: Master socket works, even new faceplate does not

Go to solution
Thank you - to be honest I'm not sure if it was this or Devon Dave's suggestion of replacing the back plate which worked, but we're now up and running.
0 Ratings
Reply