cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MelvynH
Beginner
837 Views
Message 1 of 6

Re: Caller Display not working

Go to solution

Hi

I have BT Broadband and caller display, both of which have being trouble free in the past, but recently I have lost caller display on my landline phone.

I've checked *#234# , which confirms the service is available to my phone.  When I unplug the router connection to the ADSL Broadband filter caller display on the phone works fine.  This seems to point to a problem with my broadband and I wonder if anyone can identify the problem and a solution.

Thanks

 

0 Ratings
Reply
5 REPLIES 5
Keith_Beddoe
Distinguished Sage
Distinguished Sage
832 Views
Message 2 of 6

Re: Caller Display not working

Go to solution

@MelvynH 

That would seem to indicate a fault with the home hub. Which BT home hub do you have?

With the home hub connected, is there any noise on your phone line?

0 Ratings
Reply
MelvynH
Beginner
821 Views
Message 3 of 6

Re: Caller Display not working

Go to solution

Hi

Thanks for the post.

No noise on the line, either with the dial tone or when speaking.

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
807 Views
Message 4 of 6

Re: Caller Display not working

Go to solution

@MelvynH wrote:

Hi

Thanks for the post.

No noise on the line, either with the dial tone or when speaking.


You could try a different microfilter, and also make sure you try it in the master phone socket test socket.

Which BT Home Hub do you have?

0 Ratings
Reply
MelvynH
Beginner
793 Views
Message 5 of 6

Re: Caller Display not working

Go to solution

Hi

I'm using a Smart Hub 2.  I changed the ADSL filter (genuine BT)  as suggested and plugged into the BT master socket.  No improvement.  I then pressed the factory reset button on the hub and success!  Caller Display now working on the landline phone.

I previously had  an unrelated problem of very slow download speed (around 1 Mbps).  I found that turning the hub off, waiting a couple of minutes, then turning it back on  got the download speed back up to 3.8 - 4.2 Mbps, so it looks like this particular hub can be problematic.

Thanks again for your help.

 

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
786 Views
Message 6 of 6

Re: Caller Display not working

Go to solution

There is an internal relay which may be operating on the line side of the home hub. If this was stuck in the closed position, then it may be causing a loss of the audio band where the caller display tones are send just before the ringing current.

Not sure of the function of the relay, but people do say that it clicks if there is no broadband input. It may be something to do with the test diagnostics, and applies an audio loop to the line.. A factory reset must have reset it back to normal.

On the very first home hubs which, were enabled for the old Broadband Talk service, the relay was there to extend the PSTN circuit to the hub phones and the socket on the home hub.

Broadband Talk was the forerunner to the new digital voice service, but had a number of reliability issues.

0 Ratings
Reply