cancel
Showing results for 
Search instead for 
Did you mean: 
DanW
Beginner
3,018 Views
Message 1 of 9

BT Broadband Extender 600 suddenly has terrible performance

We use a pair of BT Broadband Extender 600 Powerline adaptors to boost the signal from our Home Hub to my son's bedroom. This worked great until a few weeks ago when they suddenly started performing incredibly poorly - speed tests on my PC, connected direct to the Home Hub by ethernet, give a d/l speed of over 66mbps. In his room, that drops to about 3mbps. He is getting a ping of over 500 in online games, which renders them basically unplayable.

All the lights on both extenders are green - no orange or red to show poor connectivity. I've swapped out the ethernet cables at both ends to make sure there's not a problem there. The problem persists. I've also reset them to factory settings, re-paired them multiple times - nothing seems to make a difference.

The weird thing is, as I say, they were working perfectly up until a few weeks ago. Nothing has been moved, no major new appliances have been plugged in, everything is the same as it was. The extenders were purchased less than a year ago.

Any suggestions would be greatly appreciated as it's a real pain in the bum!

0 Ratings
Reply
8 REPLIES 8
Distinguished Sage
Distinguished Sage
3,009 Views
Message 2 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance

To check there is nothing wrong with the Homehub's Ethernet ports have you tried plugging the master powerline  adaptor into the good port that your PC is using.

If no change, the problem could be with your electrical wiring. Try plugging the adaptors into different electrical sockets.

If still no change, to rule out any thing in your house or home wiring causing the problem are you able to use the powerline adaptors at a friend or relatives house in order to see how the perform.

If the perform OK the problem would appear to be with your electrical wiring.

If they perform poorly it would tend to point to a faulty adaptor.

0 Ratings
Reply
DanW
Beginner
3,003 Views
Message 3 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance

It's not the router ports - tried swapping everything around on those, same problem.

And it's not the plug sockets - tried plugging the extender into different sockets (those that are within reach anyway) and the problem remains.

Can't really test them in somebody else's house - and as I said, this setup was working fine from late last year to just a few weeks ago, so if it was the house wiring it seems like that would have been an issue from the start?

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
3,000 Views
Message 4 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance


@DanW wrote:

 

Can't really test them in somebody else's house - and as I said, this setup was working fine from late last year to just a few weeks ago, so if it was the house wiring it seems like that would have been an issue from the start?


Not really, it could be a device that is plugged into your electrical circuit that is now introducing noise/interference and as a result is  affecting the signal to the powerline adaptors.

It is possibly a faulty adaptor but by testing them else where would prove it.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
2,994 Views
Message 5 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance

If nothing has changed then it sounds more like a faulty adapter



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
DanW
Beginner
2,990 Views
Message 6 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance

There are no major new appliances, nothing extra plugged in. I've ordered a replacement set of extenders. Hopefully that will fix it.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
2,986 Views
Message 7 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance

There does not need to be any new appliances or anything extra plugged in. Devices that you already have and are plugged into your electrical system can introduce noise into the circuit without displaying any other effects.

I agree that it is probably a faulty extender but for the sake of a bit of diagnostics and trying the adaptors else where you could have confirmed it.

Hopefully the new set you have purchased will fix your problem.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
2,955 Views
Message 8 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance

Have you tried a factory reset of the home hub, as it has been known for it to give poor connections to a specific MAC (Hardware) addresses after a while as its internal table runs out of space?

A factory reset is the only thing that resets this data.

A lower speed can also indicate that the adapters are not communication with the home hub at the correct speed due to a duplex mismatch. This can also be caused by the home hub, and a factory reset normally resets all of the home hub internal hardware.

 

0 Ratings
Reply
Highlighted
Anotheruser1
Beginner
2,858 Views
Message 9 of 9

Re: BT Broadband Extender 600 suddenly has terrible performance

Make sure your are not using any socket extensions.
My advice is to pair the two by locating a double socket and insert them next to each other.
Use a good quality cat 6 Ethernet cable not cat 5. Cat 6 Ethernet has super speed I use this to transfer HD from my PS4 downstairs via cat 6 to tv upstairs and just take the controller to bed. . The cable you get with your router I always fling as it’s poor.
Message me if you want to know how to make your HD connection go through network cable and convert back to HDMI connection at other end. Works up to 20 metres easy.
0 Ratings
Reply