cancel
Showing results for 
Search instead for 
Did you mean: 
DavidF1
Beginner
472 Views
Message 1 of 10

BT HomeHub 6 DHCP IP address allocation not working

I have had a HH6 for some time now. The firmware version is SG4B1000B540

I changed the internal LAN so the IP address on the HH is 192.168.0.1.

I set a DHCP scope of 192.168.21 - 40 and I am sure this used to work. But I have had it turned off for quite a while as I use static addresses for both wired and wireless devices thorugh the house.

However (and unfortunately), I am having a wireless device fitted at home shortly that ONLY used DHCP. You cannot configure a manual address on it. However when I turned DHCP back on I cannot pick up an IP address from the HH. I have tried it on a laptop wirelessly and also on an Android phone but to no avail. The wireless card on the laptop thinks it is connected at the MAC level but it does not pick up an IP address. The HH also thinks the laptop is connected. It shows the following message in the log

wl1:A WiFi device <C0:38:96:89:16:59> has successfully connected to SSID (Device/WiFi/SSIDs/SSID[WL_PRIV2G])

I tried picking up a DHCP address on the laptop through a wired connection but this also fails. 

The laptop work perfectly when I configure static IP addresses on both wired and wireless adapters. The phone also works with a static IP address.

Lastly, I tried connecting the laptop to BTWiFi-with-FON and I get exactly the same result. No IP address is allocated but the HH sees a connection. Here is the log entry

wl1.1:A WiFi device <C0:38:96:89:16:59> has successfully connected to SSID (Device/WiFi/SSIDs/SSID[WL_REDSIDE_O1_2G])

I have tried powering the HH off and on several times but this makes no difference. I am rapidly coming to the conclusion that I need a new HH. But, if this is a software fault it could re-occur. I think I might then need to replace the HomeHub with a different manufacturers router

I would be grateful for any advice or guidance.

Thanks for your help.

Dave

 

Tags (1)
0 Ratings
9 REPLIES 9
Distinguished Sage
Distinguished Sage
461 Views
Message 2 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working

Try a factory reset of the hub and start again. Press the recessed button with a pin for about 20 seconds until the lights flash.

Is there a particular reason for changing the sub-net?

0 Ratings
Distinguished Sage
Distinguished Sage
459 Views
Message 3 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working

Welcome to this user forum.

The DHCP server on all of the home hubs is very unreliable. When I used to use a home hub, I used a DHCP server on a wireless access point, and turned the home hub DHCP server off.

There are plenty of alternative routers you can use, instead of the home hub. Or you could ask BT for a replacement home hub, but the problem may still be there.

Here are a couple of suggestions.

TP-Link AC1200 Wireless Dual Band VDSL/ADSL about £67

https://www.tp-link.com/uk/products/details/cat-15_Archer-VR400.html#specifications

If you only want single band wireless, then this one.

The TP-Link TD-W9970 for about £40 or less. (I use this one)

https://www.tp-link.com/uk/products/details/cat-15_TD-W9970.html#specifications

They both work will all BT services, including BT YouView.

0 Ratings
DavidF1
Beginner
444 Views
Message 4 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working

A couple of years back BT sent me the new HH. Previously I was using a Netgear. But I have loads of static IP devices and 2 other routers all configured on the 192.168.0. network and I didn't want to have to reconfigure all of that lot. So it was easier to change the IP and DHCP range on the HH. Is there any significance in that BTWiFi-with-FON is also not working and that is on default setup?
0 Ratings
V_Meldrew
Expert
443 Views
Message 5 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working

You say you changed the IP address of the HH to 192.168.0.1 and set a DHCP pool of 192.168.21 - 40 is this a typo?

The first three octects of the pool address range should be the same as the first three octects of the hub address, i.e 192.168.0

 

 

0 Ratings
Distinguished Sage
Distinguished Sage
431 Views
Message 6 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working


@DavidF1 wrote:
A couple of years back BT sent me the new HH. Previously I was using a Netgear. But I have loads of static IP devices and 2 other routers all configured on the 192.168.0. network and I didn't want to have to reconfigure all of that lot. So it was easier to change the IP and DHCP range on the HH. Is there any significance in that BTWiFi-with-FON is also not working and that is on default setup?

Have you tried a factory reset?

0 Ratings
DavidF1
Beginner
400 Views
Message 7 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working

Sorry this is a typo. It should read 192.168.0.21 - 40
0 Ratings
DavidF1
Beginner
396 Views
Message 8 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working

I haven't tried a factory reset. I am kind of nervous that if there is a partial failure with DHCP, then a factory reset might wreck it completely and leave me without any broadband.
0 Ratings
Distinguished Sage
Distinguished Sage
385 Views
Message 9 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working


@DavidF1 wrote:
I haven't tried a factory reset. I am kind of nervous that if there is a partial failure with DHCP, then a factory reset might wreck it completely and leave me without any broadband.

It will not prevent connection to broadband, as its restores it to a working condition.

0 Ratings
Highlighted
Distinguished Sage
Distinguished Sage
376 Views
Message 10 of 10

Re: BT HomeHub 6 DHCP IP address allocation not working

A factory reset is by far the most common cure for hub problems, particularly dhcp problems.
0 Ratings