cancel
Showing results for 
Search instead for 
Did you mean: 
G3NID
Aspiring Contributor
239 Views
Message 11 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

I too have a device that has a fixed IP in the range 192.168.0.xxx to which I  assume that I cannot reach because the BTHub6  restricts the service address range to 192.168.1.xxx.  I come late to the problem, but I have spent hours looking to see if anyone has found a way to change the DHCP service address range.  Is there a solution?

G3NID

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
229 Views
Message 12 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

It would be much simpler to give that device a 192.168.1.xxx address

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
219 Views
Message 13 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

However, if you really want to change the Hub subnet you can do it in Advanced settings > My Network > IPv4 configuration

0 Ratings
Reply
G3NID
Aspiring Contributor
201 Views
Message 14 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

Many thanks for your 2 responses.  I have tried changing the device IP as you suggested.  However, this leads to other complications restricting my ability to access the device software.  I have also tried, unsuccessfully, to change the Hub sub net number to 0.  I will try again, but I seem to be doing something wrong.

Again, thanks.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
192 Views
Message 15 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

Couple of things, did you save the changes and did you change the gateway address to the 0 subnet?

0 Ratings
Reply
G3NID
Aspiring Contributor
173 Views
Message 16 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

Thank you.  I'll play some more and then come back to.  It may be a day or two!   Being pretty ignorant, it takes me a while to get my head round what I am doing. I am grateful that you are trying help.

 

0 Ratings
Reply
V_Meldrew
Recognised Expert
163 Views
Message 17 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

Remember to change the DHCP range as well otherwise you'll have other problems

0 Ratings
Reply
G3NID
Aspiring Contributor
150 Views
Message 18 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

Many thanks to you and Liquorice for your help.  Well, this is a success story!   After a number of iterations, I was finally able to change the DHCP Server Address Range from 192.168.1.64- 192.168.1.253, and the Hub IP 192.168.1.254 to the range 192.168.0.1- 192.168.0.253, with the hub now at 192.168.0.254.  These were, after several attempts, acceptable.  When I tried to save the settings, the computer threw a wobbly and went into a long script loop. Killed that and returned to Save.  Took the dog for a walk, and it was still trying to save!  Killed that and tried to re-enter the hub.  Bingo, worked fine on 192.168.0.254.  Checked everything, and saved  everything again.  DHCP has now changed all the IPs to reflect the change in subnet, and I am now able to access the fixed subnet 0 devices.

So, many thanks again.  Could not have done it without you.....will be in touch when it all falls apart!

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
142 Views
Message 19 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

You need to restrict the DHCP range so that it doesn't include the address of the device with the static address or you may get conflicts. That's why the address range starts at 64 rather than 1, leaving 1-63 for static addresses.

0 Ratings
Reply
V_Meldrew
Recognised Expert
140 Views
Message 20 of 24

Re: BT HomeHub 6 DHCP IP address allocation not working

Pleased to hear you've made progress but it's not wise to set the DHCP Pool to cover the full range of available addresses. From what you've said you're using some static IP's but you haven't catered for this in your DHCP values and could end up with IP clashes. I suggest you set the "Server Address Range" to something like 192.168.0.64 - 192.168.0.253 to avoid this

0 Ratings
Reply