cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
SR27
Aspiring Contributor
2,745 Views
Message 1 of 4

BT Smart Hub 2 No Internet on Laptop

I had Infinity 900 installed today, with a Smart Hub 2. The SH2 is an upgrade from a SH1.

I am well aware of the internet issues with the SH2, having already bypassed having to use it once the last time I upgraded my package.

Now I am forced to use the SH2 as Infinity 900 won't work with a SH1. So alas, all my problems are back again.

To cut the story short, the SH2 wont work with any of my computers/laptops. Both wireless and wired won't allow an internet connection because of the well known DNS proxy issue with this router. Computers can see the connection, but won't allow internet access.

I can get internet on my phone, TV, PS4... so on and so forth, but the hub refuses to work with a computer.

The computers use Windows 10 (again I am well aware of the problems between SH2 and Win 10).

As per every other person who has had this issue... it is only the SH2 that produces this problem, the previous models worked perfect.

To save you all some time, I have trawled the web, including this forum for a fix, and nothing works. 

So my question is... now I am forced to use the SH2... what are BT going to do to fix this issue that has been around for years now. Is there even a fix? Or are all of my computers now useless because of a design fault in this hub. 

Please help where you can... it is a common enough issue that someone must have some insight into it. 

Thank you.

0 Ratings
Reply
3 REPLIES 3
imjolly
Distinguished Sage
Distinguished Sage
2,735 Views
Message 2 of 4

Re: BT Smart Hub 2 No Internet on Laptop

if you have FTTP it is not you can't use the SH1 it is probably because the SH1 does not have a WAN port whereas the new SH2 does which is needed to connect to openreach ONT

I assume as you say you have read and done everything suggested by forum that smart setup is disable

have you checked the driver for computer network card is up to date



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
SR27
Aspiring Contributor
2,723 Views
Message 3 of 4

Re: BT Smart Hub 2 No Internet on Laptop

Thank you for the help, by some divine miracle I now have an internet connection... somehow a virtual port was seen by the computer as an active connection, and thus overriding the actual connection both wired and wireless. 

This same set up was somehow across all of my machines, and SH2 just sat behind the virtual port.

Crazy odd and took 4 hours to hunt down, but thats one item fixed.

Now we have the repeating Resolving Host on every web page... another battle to hopefully fix. 

 

0 Ratings
Reply
kensington3
Beginner
2,367 Views
Message 4 of 4

Re: BT Smart Hub 2 No Internet on Laptop

I'd just like to add that I have just had a similar problem, if not identical, and raised it with BT today, who couldn't nail down the problem, but have escalated the issue. I've had no problems with my BT Homehub5, but have just upgraded to BT Smart Hub 2.

There is no longer a choice as to whether 2.4GHz or 5GHz WiFi is chosen as this happens automatically. All smartphones and tablets connect and work without a problem. The issue is with my PC. It is trying to connect with 5GHz, but the WiFi connection is flaky. Even when it does connect, it won't connect to the internet. Occasionally, it does, but not for long.

I've connected the PC to the router with an ethernet cable and that then connects to the internet without problem, but I can't have permanent trailing wires. So while BT come up with a solution, I have a workaround.

Using 192.168.1.254 to access the Smart Hub menu, I've turned OFF the 5GHz WiFi. Now the PC connects without problem to the router and internet and appears to be stable. Of course, all the other devices now have to use 2.4GHz.

I'm waiting for BT to come back to me.

0 Ratings
Reply