cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
NAROBS
Contributor
1,120 Views
Message 1 of 2

BT Smart Hub 2 not responding fully to static IP address request from Epson Printer

I have been trying to set up my home networked  Epson printer with a static IP address on the wired network.

Using the "Manual settings" menu in the printer control panel  I was able to set the printer  IP address to 192.168.1.65

I then went to the BT Smart Hub  2, on which the DHCP service had previously been customised to only operate in the address range 192.168.1.85 - 192.168.1.110, and, then,  in the devices page set the printer address to 192.168.1.65 and ensured that the "Always use this address" entry was set to "Yes" and  the "Network type" was set to "Wired".  These settings were then saved and after a restart of the hub were displayed without error.

However, the the " Type of IP addressing" is still displaying as "DHCP" and not s"Static", despite numerous re-starts of hub, computer and printer. Nevertheless, when a printing request (For a test page) is made from the computer, the printer prints it out without issue.

Is this just a cosemetic issue or is there a real problem here ?

Any ideas ?

Thanks in advance.

0 Ratings
Reply
1 REPLY 1
licquorice
Distinguished Sage
Distinguished Sage
1,110 Views
Message 2 of 2

Re: BT Smart Hub 2 not responding fully to static IP address request from Epson Printer

A static address can only be set on the device itself, as you have done with the printer.

What you are attempting to do on the hub is to also set a reserved address (incorrectly known as a static address) which is allocated by DHCP. This is not only not required but may cause problems.

0 Ratings
Reply