cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
12,211 Views
Message 1 of 9

BT Smart Hub with TP-Link Deco mesh wifi

Hi,

First off, my knowledge of all things network, IT etc is basic. On a scale of 0-10 where 0 is literally none and 10 is IT network professional, I’m a 2 at best. I vaguely know what an IP address is and had heard of DHCP but no idea of what it meant. After a bit of research I think it allocates IP addresses to devices. I've heard that it’s not possible to have two DHCP gizmos allocating IP addresses on the same network.

I’m beginning to come to the conclusion that the three main items ofmy current set up of BT Smart Hub (type A), the Deco mesh system, and the Netgear switch just aren’t compatible when all connected. Either the switch or Decos are fine with the hub but not both together. I have turned off the wifi on the hub so try to simoplify things.

I tried various set ups. Firstly, connecting the primary Deco to the switch which in turn is connected to the Smart Hub. The wifi devices kept losing their internet connections – roughly every minute or two – so not acceptable or even workable. Secondly, I  switched the order so it’s hub to primary deco to switch. The wifi on devices such as phone, tablet etc is great but all the wired devices have no internet connection. I did try to run the Widows 10 network diagnostics tool. Most of the time on most of the devices (connected to the switch) it said it couldn’t get a network connection but once I did note that it said it couldn’t obtain a valid IP address. On two of the PCs they wouldn’t even connect to the Deco in the same room, even with the ethernet adapter disabled. I also have Seagate Personal Cloud NAS connected to the switch by ethernet cable and can't access that either.

Apparently it’s not possible to turn off DHCP on the hub but it should be possible to connect to a LAN port. I looked into this but my hub doesn’t have a dedicated LAN port, however, all four ethernet ports should act as LAN ports. (my previous hub did have a red WAN port but the current one doesn’t).

I live in a large eco home with lots of insulation etc so wifi (and mobile phone) reception isn’t great. I don’t want to be totally reliant on wifi, especially for desk top PCs etc. Prior to buying the mesh Decos, I had three wifi groups – one from the hub, one from a TP-link wifi gizmo connected to the switch via ethernet and my old BT Hub-4 converted to a wifi only hub (again connected to the switch via ethernet). Thisset up  worked fine for a couple of years but it meant that moving room to room involved connecting to a different wifi network every time – hence the desire for a mesh system. I read that the mesh could be improved by “ethernet backhaul” and that’s why I bought the Decos. I’m beginning to wish I hadn’t bothered!

Any suggestions would be appreciated.

0 Ratings
Reply
8 REPLIES 8
12,198 Views
Message 2 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

@Pedr057 

If you are using the TP Link Deco with the home hub, the Deco need to be in access point mode, not router mode. I assume you have it configured that way? Router mode is only intended to be used with a separate modem.

You can change the mode from the advanced settings on the Deco app.

Access point mode allows the home hub to act as the DHCP server. The addition of an Ethernet switch should not affect that. You have four Ethernet ports on the home hub, so really an Ethernet switch should not be needed.

0 Ratings
Reply
12,193 Views
Message 3 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

Yes, I have already turned the Deco mesh devices to 'access point' mode.

I have desktop PCs in three different rooms sodo need a switch and network.

Tags (1)
0 Ratings
Reply
12,164 Views
Message 4 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

As you say, BT Hub-> to Deco Mesh-> to switch->device should work.

You say you have the Deco Mesh in AP mode.

I would disconnect the Deco mesh from the hub. Restore the Deco mesh to factory settings.

Restart the hub.Switch the hub wifi off

Connect the primary mesh. Check things are working.Wifi and ethernet if possible.

Connect satellites. Check things are working.Wifi and ethernet if possible.

Connect switch. Check things are working.

If that doesn't work, you can run the Deco Mesh in router mode. This can to lead to "double natting - DHCP" problems but not always. Make sure in this case the Hub wifi is off and no other devices are ether netted to it.

 

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings icon. If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted solution’
12,123 Views
Message 5 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

I also consulted TP-Link's technical support. They suggested a couple of ways of configuring the wiring including BT Smart Hub to primary Deco to switch. I hadn't noticed that they'd titled this diagram  'router mode' and it didn't work. I thought there might be a fault with the switch and/or I'd somehow created a network loop.

After a couple of days I revisited their suggestions and noticed the title of this one said 'router mode' and realised my Decos were still in 'access point mode'. I also read this: https://www.tp-link.com/uk/support/faq/1794/

I reset the Decos to router mode, reconnected all the ethernet cables (including Deco backhaul), rebooted the switch and everything seems to be fine - touch wood.

 

0 Ratings
Reply
12,116 Views
Message 6 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

If you have the TP-Link in router mode, you will have 2 networks and will be double natting. As long as you are not into gaming or need to connect devices between the 2 networks, it shouldn't be a problem.

12,105 Views
Message 7 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

By two networks, do you mean wifi plus Ethernet or two wifi networks? If the latter, I’ve turned off wifi on the hub. If the former, I don’t do gaming etc so hopefully this won’t be a problem for me.

0 Ratings
Reply
12,102 Views
Message 8 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

Neither, you will have 2 discrete subnets, the BT hub will have a 192.168.1.nnn network and the Tp Link will be a different subnet, probably 192.168.2.nnn or 192.168.0.nnn

0 Ratings
Reply
3,477 Views
Message 9 of 9

Re: BT Smart Hub with TP-Link Deco mesh wifi

This is a continuation of an earlier post. 

I have a Deco X60 Mesh with 3 satellites. These have a wireless password and was connected to the broadband by an ancient Openreach router. I upgrade through EE/BT and got a BT SmartHub (SH20A) which I set up but would not accept the same password as the Deco X60 Mesh. I tried to contact BT by all the normal means, this failed. I was stuck and then did the search and found this feed.... and thanks for that. Just wished to add some more detail to my experience.

Firstly, read https://www.tp-link.com/uk/support/faq/1794/ where there is a discussion about Ethernet Backhaul whatever that really means.....

The SmartHub has 4 ethernet ports, one marked WAN. This is the sequence I used :

- Turn the DECO system off (base station and satellites).

- Use the BT app to connect to the SmartHub and set it up as described in the manual, change the wireless password to the same one that you are using on the DECO. Check that the internet is all good, switch the Smart Hub off.

- Switch on the DECO base station only without any connections, the light goes red, log into the system with the DECO app and check the wireless passwords are exactly the same between the 2 systems. I kept the same password as I have many devices that log into the DECO password so did not want to go through the thrill of changing them.

- In the Deco app, go to the Advanced menu to change the Deco operation from "router mode" to "access point" mode and allow the system to do its thing. Check that you can see the base station on the Deco app. Switch off the Deco.

- Restart the SmartHub, connect an ethernet cable from one of the ethernet ports in the SmartHub (not the one labelled WAN) to the Deco, check that the internet is accessible on wireless.

- All OK,  switch on the Deco (the light should go red to green after some flashing). Check that the internet is accessible on wireless. I have a guest wifi so can see that the Deco is working too. Check the broadband speed is always a good idea. You are ready to go and add the satellites.

- Get one of the other satellite Decos, connect this by Ethernet cable to the Deco base station (do not take the ethernet cable out that is the connection with the SmartHub), power up the satellite, flashes red then eventually green, check the internet - the satellite should be seen on the Deco App. Power down the satellite, remove the ethernet cable and restart the satellite, flashes red then goes green, check that it is a satellite on the Deco App.

- Check the internet and the Deco App to check all is good with the system.

- Resite the satellite (no ethernet cable is needed) from where it originated, check the Deco app when it restarts.

- Repeat the process with each satellite.

I hope this works for you guys.

 

0 Ratings
Reply