cancel
Showing results for 
Search instead for 
Did you mean: 
Sirbu
Aspiring Contributor
406 Views
Message 11 of 20

Re: Gmail - Outlook - Not working on new smart hub.

Thanks for the explanation that the previous Home Hubs don't support IPv6 and probably BT Wifi-with-Fon too.  Still doesn't explain why the BT Smart Hub doesn't drop back to IPv4 if a site can't be reached via IPv6 which you said ought to happen.  That suggests to me that the problem lies with the Smart Hub.  Is there anyway to disable IPv6 in the Smart Hub so that it only connects via IPv4 like previous Home Hubs?

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
404 Views
Message 12 of 20

Re: Gmail - Outlook - Not working on new smart hub.

This is getting confusing replying on 2 threads, please stick to one thread. I have explained on the other thread that it is your PC not the hub that drops back.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
399 Views
Message 13 of 20

Re: Gmail - Outlook - Not working on new smart hub.

I have put all your posts on this thread to avoid further confusion.

0 Ratings
Reply
Sirbu
Aspiring Contributor
384 Views
Message 14 of 20

Re: Gmail - Outlook - Not working on new smart hub.

Thanks for consolidating the threads.  I missed your previous post about about it being XP and not HH6 which should drop back.  I see though that this problem has affected a number of other Smart Hub users e.g. "Smart hub nightmares" and that it appears not to be possible to disable IPv6 in HH6.  Since XP apparently has an IPv6 capability via Microsoft TCP/IP version 6 I wonder why it cannot function with HH6.  Also why does Outlook work ok with the BT Mail website and not other email websites.  Lastly, if all else fails can I not revert to a Home Hub 5?

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
381 Views
Message 15 of 20

Re: Gmail - Outlook - Not working on new smart hub.

Windows XP may have a rudimentary IPv6 capability but I'm not sure it is fully functional. Disabling IPv6 in network settings should persist through re-boots so is probably the simplest option. Sites will work differently depending on their IPv6 capability and what DNS lookups return for those sites. You could revert to a Hub5 if you have one spare, but that may well get upgraded for IPv6 in a future firmware update.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
366 Views
Message 16 of 20

Re: Gmail - Outlook - Not working on new smart hub.

@Sirbu As an experiment you could try setting Google's IPv6 DNS servers in your network adaptor.

Go to Control Panel, Network Connections.  Then select Wireless Network Connection, Properties highlight Microsoft TCP/IP version 6, click on Properties and then set as screenshot below.

 

ipv6dns.jpg

0 Ratings
Reply
Sirbu
Aspiring Contributor
357 Views
Message 17 of 20

Re: Gmail - Outlook - Not working on new smart hub.

I would try this but the Properties button for Microsoft TCP/IP version 6 protocol is greyed out, whether it is selected or not, so that its properties cannot be changed.  Does this suggest that the protocol is not installed?

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
349 Views
Message 18 of 20

Re: Gmail - Outlook - Not working on new smart hub.

Or not installed fully. If the install button is clickable when the Properties button for Microsoft TCP/IP version 6 is highlighted, try installing it.

 
0 Ratings
Reply
Highlighted
Sirbu
Aspiring Contributor
333 Views
Message 19 of 20

Re: Gmail - Outlook - Not working on new smart hub.

So I uninstalled IPv 6 and as expected MS Outlook was able to access my Gmail account ok.  I then reinstalled IPv6 and as before MS Outlook returned an error when trying to access Gmail, unless IPv6 was disabled.  I also checked the email account settings for Gmail and BT Yahoo Mail and there was no apparent difference between them.  I was  unable to access the IPv6 properties to make the changes you suggested as the Properties button is still greyed out.  Would it be possible to change the settings via the Command Prompt?  Anyway, further investigation on the internet suggests that the IPv6 implementation under Windows XP might be rather flaky so getting it to work correctly with the Smart Hub might not be possible. This still leaves the question as to why MS Outlook works ok with BT and Yahoo Mail accounts but not with others.

Tags (1)
0 Ratings
Reply
Distinguished Sage
Distinguished Sage
323 Views
Message 20 of 20

Re: Gmail - Outlook - Not working on new smart hub.

Yes, I agree the  implementation of IPv6 in Windows XP is somewhat flaky and not fully functional. Its possible to change the DNS servers via the command line for IPv4 but I'm not sure of the syntax for IPv6. Google 'netsh' for instructions.

The reason that Yahoo and BTMail work ok could simply be that they haven't implemented IPv6 yet so Outlook is not even attempting to connect via IPv6 and thus not failing.

As stated in a previous post, I really recommend that you upgrade to a more secure operating system than Windows XP.

Edit: The following works in W10 where "Local Area Connection" is the name of your wireless adaptor without the quotes.

For the primary DNS server run:

netsh interface ipv6 set dns name="Local Area Connection" static 2001:4860:4860::8888

For the secondary DNS server run:

netsh interface ipv6 add dns name="Local Area Connection" 2001:4860:4860::8844 index=2 

 

0 Ratings
Reply