cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Kevyn
Aspiring Contributor
2,056 Views
Message 1 of 3

BT complete Wi-Fi and Halo. Wi-Fi Disc issue

Hello, Pulling my hair out with this one!

 

I have a BT Smart Hub 2 and 3 X Wi-Fi discs (black discs).  Up until this point the three discs have been rock solid,  giving me WiFi  throughout my property, faultlessly. 

Now 2 of the 3 discs will not connect to the Smart Hub 2 wirelessly.

 

Background

On Wednesday I noticed that one of the discs was flashing blue indicating it was trying to make a connection to the smart hub.  After rebooting,  the disc displayed a consistent red flashing light.

My assumption was that the disc had lost its configuration. 

I removed the red flashing disc from its home location ,moving  it to around 3 meters (line of sight) from the Smart Hub.  I proceeded to try and re-configure the wifi disc to connect to the Smart Hub 2. 

I have tried both  Ethernet and the WPS configuration methods.  Trying both the Smart Hub 2 config. via “add new wifi disc” (advanced wireless/configuration/my discs) and Android “My BT” App. Add new disc wizard.

Ethernet configuration registers the disc on the network, producing a solid blue light (have left connected to Ethernet for  12 hours) .  However, once removing the Ethernet cable and rebooting the disc the disc changes to either red flashing or blue flashing.  This is within 3 meters of the hub, in clear line of sight. 

Using WPS will a) not pick up the disc or b) will attempt to add the disc (asking me to provide  a friendly name for the disc) but when wizard finishes the discs drops back to flashing blue then flashing red.

I have tried using the factory reset pin (pressing for 10 seconds whilst powered) and waiting for reboot. To no avail

 

I have also unplugged my working garage black disc (which was again, working flawlessly for over 6 months) with the intention of replacing  what I Have deemed as a faulty disc.  However on startup the once working disc will no longer connect.  Tried the same failed steps, as above. 

I now have two discs that will not connect to my Smart Hub 2.  The third disc has not been unplugged and is still working and connecting clients.  I am obviously reluctant to power this disc off as its working fine!

  • I have rebooted the Smart Hub 2 several times, to no avail.
  • I have had no mains power cuts, surges or spikes (I have a UPS that will alert me if the mains fluctuates).
  • The Android “My BT” app indicates that each one of my disc locations has either “good” or “excellent” wifi signal from the Smart Hub 2 and has been such for 6 months+.

 

 

After spending hours on this, I have spoken to BT and they are not sure what is wrong but are sending replacement discs, which I suspect will not make any difference (2 discs with the same fault) after disconnecting.

 

I am suspecting a Firmware issue here.  I did notice that BT appear to rolling out firmware for the discs. One of the broken discs upgraded firmware revision  whilst connected to Ethernet.

 

Smart Hub 2 Firmware

Firmware version:v0.17.01.12301-BT

Firmware updated:Sat Mar 14 14:05:41 2020

 

 

BT Complete Disc firmware (x3)

Firmware version:

0.16.00.07230

 

 

I am very reluctant to reset my Smart Hub 2 to factory defaults, owing to having reconfigure  detailed config.  (password, SSID, Wireless, Firewall rules, VPN, DHCP reservations etc etc). 

I am also assuming that a factory reset and a restore of config (from backup) would probably NOT be recommended.

 

I could really do with somebody technical who knows some detail about this stuff and how it meshes together. 

 

Anybody else having these problems recently?

 

Many thanks for your help

 

 

 

 

 

0 Ratings
Reply
2 REPLIES 2
LordDarkenon
Beginner
1,756 Views
Message 2 of 3

Re: BT complete Wi-Fi and Halo. Wi-Fi Disc issue

Did you manage to get anywhere with this?

I'm having the same issues with SH2 and 2 black complete wifi discs.  They keep on disconnecting every couple of days - I usually notice in morning when they are flashing red.  Usually turning the SH2 off and on will make them re-connect - but this isn't a solution.   

I started with 1 disc, which worked without problem since installation for about 6 weeks, and then over the last couple of weeks I've had disconnects every couple of days.  I contacted BT and had another disc sent out, and that has the same problem.

It's got to be a firmware / software issue.  It's like rebooting the SH2 clears a temporary cache, and when that gets full after a couple of days the discs disconnect again.

I'm at the point of disconnecting them completely since I don't want to be rebooting my SH2 every couple of days.

Another BT issue they seem to be ignoring - or the forum moderators just reel out the old chestnut 'have you tried resetting your hub and discs' - as if that's a solution you can do every couple of days. 

0 Ratings
Reply
Kevyn
Aspiring Contributor
605 Views
Message 3 of 3

Re: BT complete Wi-Fi and Halo. Wi-Fi Disc issue

Sorry for delay in responding - no didn't get anywhere with my post here, however in the last few months the disks and the router seem to have stabilised , I am assuming this is to do with maybe a firmware update on the disks?

The disks are all now running 

Firmware version:

0.23.00.0807

 

 

 

 

If any of the disks lose connection I find I have to reboot the SH2 (router), and they magically reconnect.

0 Ratings
Reply