cancel
Showing results for 
Search instead for 
Did you mean: 
31,257 Views
Message 1 of 31

BT infinity with a Cisco router

Go to solution

Hello Im looking to configure a new Cisco 887va router to use Bt infinity service. So far it has not been able to connect. The router staes it natively supports VDSL2 so i assume that i configure the dialer interface unlike some other examples of people using PPPOE here.

 

Has anyone done this successfully and if so could they give me some pointers?

 

 

0 Ratings
Reply
30 REPLIES 30
deathaxe
Expert
31,244 Views
Message 2 of 31

Re: BT infinity with a Cisco router

Go to solution

The most important thing is that you need to set the multi-Vlan up and your login details.

 

Here is the setup guid for the draytek 2750n modem/router and there is the correct setting for infinity.

 

http://www.broadbandbuyer.co.uk/Shop/PageTextDetail.asp?SetID=4&TextID=1004

0 Ratings
Reply
31,170 Views
Message 3 of 31

Re: BT infinity with a Cisco router

Go to solution

Thank you for the reply, im intrested in seeing if someone has managed this on a cisco router and if they are willing to share the config.

 

I have configured the router already im hoping to use the dialer and completely replace the hub and modem provided by BT.

 

Has anyone tried this?

 

 

0 Ratings
Reply
Lobotomised
Newbie
31,138 Views
Message 4 of 31

Re: BT infinity with a Cisco router

Go to solution

Not done this myself for a long time but I reckon this page might help you?

 

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080126dc0.shtml

 

 

0 Ratings
Reply
Lobotomised
Newbie
31,137 Views
Message 5 of 31

Re: BT infinity with a Cisco router

Go to solution

<ignore>

0 Ratings
Reply
31,085 Views
Message 6 of 31

Re: BT infinity with a Cisco router

Go to solution

Thanks for your replies to go a bit further

 

Im setting up a CISCO887VA-SEC-K9 router to use BT infinity. Im looking to use PPOE with a passthrough to the BT Modem.

I have all the interfaces up but when i test the connection I get a line down message.

Below is my config I wanted to enable all the ports to use the VLAN but despite doing no shut the router is not pingable on all but the last port.

Any help is gratefully recieved


controller VDSL 0
!
bba-group pppoe global
!
interface Ethernet0
no ip address
!
interface Ethernet0.35
encapsulation dot1Q 35
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
shutdown
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
switchport access vlan 100
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0
ip flow ingress
ip nat inside
no ip virtual-reassembly in
ip route-cache policy
ip tcp adjust-mss 1452
!
interface Dialer1
description VDSL
mtu 1492
ip address negotiated
no ip redirects
no ip proxy-arp
ip flow ingress
ip nat outside
no ip virtual-reassembly in
encapsulation ppp
ip route-cache policy
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username <username> password 0 <password>
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer1 overload
!
logging esm config
access-list 1 permit any
access-list 100 permit ip 10.0.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!

0 Ratings
Reply
perksta
Beginner
31,031 Views
Message 7 of 31

Re: BT infinity with a Cisco router

Go to solution

Have you seen the config at the bottom of this page

 

http://www.dslreports.com/forum/r26643011-Config-Cisco-1921-and-HWIC-1VDSL

 

0 Ratings
Reply
Highlighted
Supplanter
Aspiring Contributor
26,093 Views
Message 8 of 31

Re: BT infinity with a Cisco router

Go to solution

Hi Newbie,

 

Your config looks good apart from et0.35 where you are tagging in the wrong vlan. It should be 101 and you can use the built in vdsl modem with no external Openreach one.

 

interface Ethernet0

 description Connection to BT Infinity (VDSL 0)

 no ip address

 

interface Ethernet0.101

 description 802.1Q Tagging for PPPoE (VDSL 0)

 encapsulation dot1Q 101

 pppoe enable group global

 pppoe-client dial-pool-number 1

 

interface Dialer1

 description I put my tel number here so I know what line is what on multiple interfaces

 mtu 1492

 ip address negotiated

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip nbar protocol-discovery

 ip nat outside

 ip virtual-reassembly in

 encapsulation ppp

 ip tcp adjust-mss 1452

 dialer pool 1

 dialer idle-timeout 0

 dialer-group 1

 keepalive 30

 ppp authentication chap callin

 ppp chap hostname youremail@btinternet.com

 ppp chap password yourpassword

 ppp ipcp address accept

 no cdp enable

 

You don't need the tcp adjusment on vlan100 just put it on di1. Not sure if you are connecting that to the openreach modem or your internal network. Looking at the config could be either. You don't want to adjust that on your internal network though. Could posibly affect internal speeds.

 

If it is connect to the openreach modem you no longer need it with the above config and can connect the router right up to the line. This way you can take VLAN100 and Fa3 off.

 

I can't see all the config but this works. Make sure the VDSL is set to auto mode and you may need to apply any relevant ACL to di1 if required. 

 

conf t

controllers vdsl 0

operating mode auto

end

 

I am flying:

 

                      DS Channel1      DS Channel0       US Channel1         US Channel0

Speed (kbps):   0                      79987                0                        19999

 

Noise Margin: 14.7 dB 23.3 dB

Attainable Rate: 11176 kbits/s 38891 kbits/s

Actual Power: 12.8 dBm  6.8 dBm

 

Hope that helps. I can mail you a complete config if need be.

Supplanter
Aspiring Contributor
26,091 Views
Message 9 of 31

Re: BT infinity with a Cisco router

Go to solution
Just seen we are all called Newbie and you username is "HelpWithCiscoConfig" sorry 🙂 lol
0 Ratings
Reply
Distinguished Sage
Distinguished Sage
26,076 Views
Message 10 of 31

Re: BT infinity with a Cisco router

Go to solution
Hi Supplanter
Good post but hopefully the OP has managed to get things sorted out before now. The post is over 2 years old but I'm sure it will be helpful to anybody who has that router. Smiley Wink
0 Ratings
Reply