cancel
Showing results for 
Search instead for 
Did you mean: 
dataghost
Aspiring Contributor
3,982 Views
Message 1 of 8

BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issue?

Hi All,

 

Initially the Smart Hub seemed amazing and I was really pleased.  However, one day out of the blue my iPad Pro could no longer connect.  In the iPad's settings I could see the SSID of the router (both of them as I have split 2.4 and 5g) and it would connect with a tick next to it, but no Wi-Fi symbol would appear at the top of the iPad screen and there was no internet connectivity whatsoever via 2.4 or 5g.  Nothing at the iPad side would resolve, I reset network settings, and eventually fully restored the iPad to no avail.  In desperation I reset the hub back to factory settings and then reconfigured everything.  This fixed the issue and my iPad Pro was able to connect again.  It worked for a few weeks until going back to exactly what I described above.

 

IMG_4006.jpg

As you can see above, connected to 5g but no wifi symbol at the top of the screen.

 

IMG_4007.jpg

Under IPV4 is shows 4 addresses...

 

IMG_4008.jpg

 

As my iPad is Wi-Fi only I am now unable to use it at all, unless I restore the hub back to factory settings again - but even then how long will it last until it decides to deny the iPad any connectivity?

 

Now another family member is having issues with an iPhone that also no longer connects to the Smart Hubs Wi-Fi.  This phone is being sold soon so its not an issue.

 

I am heavily reliant on my internet connection and wonder which device the hub will decide to lock out next.  I have seen a lot of complaints around connectivity with this router, but does my specific scenario about sound like the same thing?

 

Also, is there anywhere online that details firmware updates for this router as Id be interested in taking a look?

 

Thanks

7 REPLIES 7
kinetic747
Contributor
3,957 Views
Message 2 of 8

Re: BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issu

It's highly likely to be the hub itself given the degree of negative feedback around. I have an Android phone and my daughter has an IPhone and we're both having the same connectivity problems, along with any other device you care to mention.
0 Ratings
cooperman
Aspiring Expert
3,921 Views
Message 3 of 8

Re: BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issu

Even a quick browse of this forum will give you an indication of the wifi problems people are experiencing with the HH6. Even the previous HH5 gave similar problems to lots of people so the issues have not been resolved.

 

The only answer would seem to be to buy a compatible router from a well known manufacturer as many of us have done. The down side of doing that is that BT will not help you in anyway if you have problems with it. Having said that I used a non BT router on ADSL for years without a problem and have also used a non BT VDSL router for some time time now also without any problems.

 

Clearly "Free" does not mean good with this BT product.

0 Ratings
Poppy7
Contributor
3,908 Views
Message 4 of 8

Re: BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issu


@dataghost wrote:

Hi All,

 

Initially the Smart Hub seemed amazing and I was really pleased.  However, one day out of the blue my iPad Pro could no longer connect.  In the iPad's settings I could see the SSID of the router (both of them as I have split 2.4 and 5g) and it would connect with a tick next to it, but no Wi-Fi symbol would appear at the top of the iPad screen and there was no internet connectivity whatsoever via 2.4 or 5g.  Nothing at the iPad side would resolve, I reset network settings, and eventually fully restored the iPad to no avail.  In desperation I reset the hub back to factory settings and then reconfigured everything.  This fixed the issue and my iPad Pro was able to connect again.  It worked for a few weeks until going back to exactly what I described above.

 

IMG_4006.jpg

As you can see above, connected to 5g but no wifi symbol at the top of the screen.

 

IMG_4007.jpg

Under IPV4 is shows 4 addresses...

 

IMG_4008.jpg

 

As my iPad is Wi-Fi only I am now unable to use it at all, unless I restore the hub back to factory settings again - but even then how long will it last until it decides to deny the iPad any connectivity?

 

Now another family member is having issues with an iPhone that also no longer connects to the Smart Hubs Wi-Fi.  This phone is being sold soon so its not an issue.

 

I am heavily reliant on my internet connection and wonder which device the hub will decide to lock out next.  I have seen a lot of complaints around connectivity with this router, but does my specific scenario about sound like the same thing?

 

Also, is there anywhere online that details firmware updates for this router as Id be interested in taking a look?

 

Thanks


Had same problem with Apple iPod and then later on an iPad mini shortly followed by kindle fire hd. Have had a replacement hub for a few days now but I don't have any confidence in it.

0 Ratings
smf22
Recognised Expert
3,862 Views
Message 5 of 8

Re: BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issu

@dataghost

 

Try changing the Wifi name (SSID) to something without spaces. I've seen other posts where connectivity was affected when using a space in the name. It's interesting that your Wifi names are completely different. The Home Hub 6 used to restrict the 5 GHz name to be exactly the same as the 2.4 GHz name with a suffix of '-5'.

 

try something simple without spaces or any other 'special' characters such as the brackets and see if that affects the behaviour.

 

As far as the IP addresses, it's difficult to see, but those in the screen shot you attached appear to be IPv6 addresses. For IPv6 it is perfectly normal for a device to have multiple addresses.

 

Regards

0 Ratings
catesby17
Newbie
3,189 Views
Message 6 of 8

Re: BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issu

Hi

 

Did you ever solve the problem as mine is identical with an ipad4 and nothing BT has sugested has worked so do I ditch the ipad or the HH6.  Don't all shout at once

0 Ratings
MorgaineD
Expert
3,176 Views
Message 7 of 8

Re: BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issu

Funny @catesby17, your question gave me a good chuckle. 🙂

But less funny is that BT has been putting Infinity users into this situation for over half a year. It's an unmistakeable sign of lack of negative feedback reaching where it matters.  The feedback process isn't working for this product or this would have been fixed ages ago, as a commodity CPE is hardly rocket science.

0 Ratings
catesby17
Newbie
3,126 Views
Message 8 of 8

Re: BY Smart Hub Wi-Fi Problems specifically with Apple devices (so far) - anyone have the same issu

I have received a replacement smart hub and guess what...my ipad now connects when for 3 days talking to BT they were insisting there was no fault in the original hub. Strange that. Be happy at least its working at the moment!
0 Ratings