cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Airwalk73
Beginner
345 Views
Message 1 of 2

Broadband - Drops whenever I use Stadia

Hi All.

I am having an issue whenever I attempt to use Stadia (online gaming service) my internet drops out.

It does not matter whether I am on my PC or using via Google Chromecast on TV, I get onto the service play for anywhere between 5 and 10 minutes then I lose signal completely.  

I have checked my speeds prior to using and am getting download speeds of 100mb+ and upload speeds of 30mb+ it all starts off fine and then as I say it just slows up fairly soon then signal lost completely.

I thought maybe it was an inconsistent wifi signal so tried via ethernet and the very same thing happens... great before i login to Stadia, fine when I first start and then very shortly after i get signal lost as if the router has blocked me for a few seconds...and then I reconnect?

I have no idea where to start with this as it is a bit of a niche question....

But any possible starters of what to check or try would be appreciated.

 

0 Ratings
Reply
1 REPLY 1
Airwalk73
Beginner
338 Views
Message 2 of 2

Re: Broadband - Drops whenever I use Stadia

Sorry forgot to mention I have the FTTP and the Fibre 100 Service and using the latest BT SmartHub.

I have also noticed that with a lot of the items on my network they have Very fast download speeds when first connected to the Hub but then after awhile I check the speed again and it has gone from over 100mbps to 10mbps. If i then disconnect an reconnect back upto over 100mbps...

So maybe the issue is not just a Stadia issue but Stadia is a service that is just more intensive and highlighting a general issue I have with either the Hub?

0 Ratings
Reply