cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Newbie1966
Beginner
1,526 Views
Message 2 of 2

Can't establish a secure connection to the server & Parental Controls problem - Solved

Problem:

Only on some websites (Social media such as Instagram, Facebook, Linkedin & Steam), getting message "Can't establish a secure connection to server"

Tried taking "s" off https// and then got blue screen message that Parental Controls were blocking access.

Couldn't get into Parental Controls via blue screen as it wouldn't have it that I was the Account holder so accessed via MY BT.

Turned off all Parental Controls - didn't fix it

Rebooted Hub - didn't fix it

Reset Hub - didn't fix it

Accessed Hub via IP address changed settings etc - didn't fix it

Contacted BT on line chat- didn't help, just suggested I turn off Parental Controls

Got put through to Technical team on same chat - didn't help, just suggested I turn off Parental Controls

They told me to call 0800 didn't help, just suggested I turn off Parental Controls, then told me to contact Technical team (I suggested not) - then told me someone would call me back in 48hrs

Tried everything again the next morning with same result.

Hub dropped off at lunchtime and came back up 10 mins later.

Got a message on my computer saying Outlook wanted to use something called Cloudflare-dns and should I trust it.

I googled Cloudfare and it seemed ligitimate so I chose to trust it. 

Now everything works. Someone who knows what this is might explain it, but I hope this helps anyone with similar problems

0 Ratings
Reply
1 REPLY 1
Newbie1966
Beginner
1,522 Views
Message 1 of 2

Can't establish a secure connection to the server

I have been suffering an issue for the past 24hours which BT were unable to help me with, which has now resolved itself and am posting this as it seems a common problem.

When trying to connect to some websites, I was getting a message saying "Can't establish a secure connection to the server". This was happening on social media sites and one of these was Linkedin, which I use frequently. The others we noticed were Steam, Facebook and Instagram. If I changed the url of any of these sites removing the "s" from https//, I got a blue message box from BT saying it was blocked by parental controls. The option at the bottom of this message gave me access to my Parental Controls but then stopped me from making any effective changes because it told me I didn't have account holder permissions (I do as I am the account holder). I went to the Parental Controls via MY BT and turned off all Parental Controls and reset it. This didn't work, so I rebooted the Hub. This didn't work so I reset the Hub. Lots of rebooting and resetting later and several visits to the Hub Manager and MY BT didn't work. I then contacted BT and got pushed from pillar to post, being asked the same questions time and again and asking me to do the same fixes to no avail. When I finally spoke to a 2nd human and got the answer I need to go back to the Technical team again, I was a little miffed. The kindly 2nd human then suggested it get pushed up a level and I would get a call back in 48hrs. Tried again the next morning with the same results and wasted a few more hours on Parental Controls and resetting hubs etc. Finally gave up. At lunchtime the Wifi randomly stopped working when I was working on emails etc. The Hub was flashing Orange, so I left it to make its own mind up and had a cigarette. When the Wifi came back on, I got a message popped up saying that Outlook wanted me to trust something called Cloudflare-dns. I didn't know what this was so I googled it and it seemed to be some ligitimate DNS resolver. I clicked on the always trust button and now everything works! I'm not a computer whizz and someone might explain this better, but hopefully this will help someone

0 Ratings
Reply