cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JohnBergqvist
Contributor
2,929 Views
Message 1 of 8

Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem

I'm trying to get IPTV to work on my YouView Box now that i've switched to an ROG GT-AC3500 Router (with a DrayTek Vigor 130 Modem), but no matter what guides I follow, I can't seem to get it working. 

 

I have enabled bridging mode on the 130 as described here: https://www.draytek.co.uk/support/guides/kb-vigor-130-bridge

 

(For those of you who can't see it: on the Vigor, I go to [Internet Access] > [MPoA / Static or dynamic IP], on that page, select Enable)

 

Then I have my router itself configured as follows, first WAN, then IPTV:

  

What am I doing wrong? It doesn't matter what I set the IPTV STB Port to, although the YouView box is physically plugged into port 1 on the router.

 

The "IPTV/ VoIP Port Settings" dropdown is either LAN1/LAN2 or "LAN5/LAN6", those are the only 2 options available.

 

The options in the "IPTV STB Port" dropdown are: "None", "LAN1", "LAN2" and "LAN1 & LAN2". In here, LAN1 and LAN2 are replaced by 5 & 6 depending on which option i've chosen in the "IPTV/VoIP Port Settings" drop-down box.

0 Ratings
Reply
7 REPLIES 7
Devon_Dave
Distinguished Guru
2,895 Views
Message 2 of 8

Re: Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem

Check this link.
https://community.bt.com/t5/YouView-Boxes/Using-a-3rd-party-router-for-Multicast/td-p/1048582
(If I have helped you in any way please click the thumbs up. Thank You)
If I have solved your Issue please click the "Mark as accepted solution" button.
0 Ratings
Reply
JohnBergqvist
Contributor
2,887 Views
Message 3 of 8

Re: Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem

Unfortunately the steps described there (especially for the ASUS one) don't match my router exactly. Look at my screenshots above, and you'll see I don't have an "IGMP Snooping" option.
0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
2,881 Views
Message 4 of 8

Re: Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem

This page mentions IPTV

https://www.eteknix.com/asus-rog-rapture-gt-ac5300-enthusiast-router-review/6/

 

Look under "Wired Network"

 

0 Ratings
Reply
JohnBergqvist
Contributor
2,831 Views
Message 5 of 8

Re: Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem

Yes, I know the router has generic IPTV functionality, but what settings in particular do I need to get this specific router to work with BT's IPTV?
0 Ratings
Reply
imjolly
Distinguished Sage
Distinguished Sage
2,823 Views
Message 6 of 8

Re: Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem

have you tried reading through the ASUS forum as you are more likely to find an answer there



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
Liam_
Recognised Expert
2,812 Views
Message 7 of 8

Re: Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem

If you haven't already got it sorted out have a look at this part of the router config.

IGMP.jpg

 

Select the port you have the TV on then enable the IGMP parts that are disabled in the image.  I don't have an Asus nor use IPTV but it seems the logical choice of settings.

0 Ratings
Reply
JohnBergqvist
Contributor
2,654 Views
Message 8 of 8

Re: Cannot get IPTV to work on ASUS/ROG GT-AC5300 Router with DrayTek Vigor 130 Modem


@Liam_wrote:

If you haven't already got it sorted out have a look at this part of the router config.

IGMP.jpg

 

Select the port you have the TV on then enable the IGMP parts that are disabled in the image.  I don't have an Asus nor use IPTV but it seems the logical choice of settings.


If you had seen the screenshots I had posted of the same screen on my router (latest firmware), you will see that I do not have those options available. 

0 Ratings
Reply