cancel
Showing results for 
Search instead for 
Did you mean: 
kket
Beginner
4,280 Views
Message 1 of 6

Cisco Router behind BT Home Hub - VPN/Telnet

Go to solution

Hi everyone,

 

I am having troubles with the Home Hub router's (I think) inbound/outbound traffic. Could anyone shed me some light please?

 

Here is my setup:

 

IMG_20140106_114113182.jpg

 

What I am trying to achieve is to allow external PCs to VPN inside to my Cisco router (VPN server already setup tested and working in internal network).

 

Here is the config files for my Cisco router:

 

Current configuration : 1382 bytes
!
! Last configuration change at 12:20:34 UTC Fri Jan 3 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
!
aaa authentication ppp default local
!
!
aaa session-id common
!
dot11 syslog
ip source-route
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group KNS-VPN
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1
 l2tp tunnel timeout no-session 15
!
crypto pki token default removal timeout 0
!
!
username ket password 0 cisco123
!
redundancy
!
!
controller E1 0/0/0
!
interface FastEthernet0/0
 ip address 192.168.1.254 255.255.255.0
 duplex auto
 speed auto
 no shutdown
!
interface FastEthernet0/1
 duplex auto
 speed auto
 Shutdown
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/0
 peer default ip address pool defaultpool
 no keepalive
 ppp encrypt mppe auto
 ppp authentication pap chap ms-chap
!
ip local pool defaultpool 192.168.1.10 192.168.1.20
ip forward-protocol nd
no ip http server
no ip http secure-server
!
disable-eadi
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 transport input all
!
scheduler allocate 20000 1000
end

 

On the port forwarding side on BT Home Hub, I have created a setting for it which is (1723) for PPTP and mapped to 192.168.1.253 which is the IP of fa0/0's Cisco router.

 

What I have tested so far is all in internal network meaning that traffic never go out the external network.

  • Created a public IP 10.10.10.1 on fa0/1
  • A computer with 10.10.10.2 connected to fa0/1
  • Computer ping fa0/1 fine
  • Computer has correct VPN configuration setup
  • Computer VPN fine and got the right pool IP address from the router (In this case 192.168.1.10)
  • Computer pings fine to gateway of internal IP address 192.168.1.253

To realistically test it out I have put this setup in a working environment with a broadband router. A picture shown on top of the post illsturate the topology. The steps what I have done it:

 

  • Cisco router used a straight through cable wired to BT home hub
  • Cisco router (192.168.1.253) pings fine to BT home hub router (192.168.1.254) and pings other networked devices fine connected wirelessly to BT home hub.
  • BT Home hub has correct port forwarding PPTP settings (TCP: 1723), I have also tried to use the pre-defined settings from the drop-down list called PPTP server/VPN.
  • Firewall disabled

I'm just running out of ideas, anyone can help me on this I will be apperciated.

 

Thanks!

0 Ratings
Reply
5 REPLIES 5
Distinguished Sage
Distinguished Sage
4,277 Views
Message 2 of 6

Re: Cisco Router behind BT Home Hub - VPN/Telnet

Go to solution

Are you a business user?

0 Ratings
Reply
Highlighted
kket
Beginner
4,271 Views
Message 3 of 6

Re: Cisco Router behind BT Home Hub - VPN/Telnet

Go to solution

No I'm not, I'm just trying to learn and study Cisco networking but I can't overcome the BT home hub issue...

 

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
4,268 Views
Message 4 of 6

Re: Cisco Router behind BT Home Hub - VPN/Telnet

Go to solution

Its probably a bit too complex for this forum, unless you can find someone with a similar setup. You may like to read the BT Business forum, and see if anyone had done anything similar.

 

0 Ratings
Reply
kket
Beginner
4,247 Views
Message 5 of 6

Re: Cisco Router behind BT Home Hub - VPN/Telnet

Go to solution

Found the problem! Router did get packets, but packets get lost on the way back to the client as I did not set the default ip gateway for the cisco router!

What I did is:

 

ip route 0.0.0.0 0.0.0.0 192.168.1.254

 
Telling all the packets to return back to the broadband router! If packets does not know the destination then the packets get forwarded to the broadband router and the broadband router or ISP network handles to rest!

0 Ratings
Reply
urssunil4u
Newbie
3,454 Views
Message 6 of 6

Re: Cisco Router behind BT Home Hub - VPN/Telnet

Go to solution

hey bud,

you doing CCNA,

heres what you have to do....

you need NAT and ACL to allow all your inside traffic. and also you need DNS server on router so it will convert IP addresses into names. 

 

one very important thing isget you NAT correct with overload. if you still interested ask me i will shoot config...

0 Ratings
Reply