Showing results for 
Search instead for 
Did you mean: 
Message 1 of 3

Company VPN not working with Home Hub 5



I switched to BT infinity a month or so ago, but have only recently tried to access my company VPN through the service (VPN uses Citrix Xenapp).  It used to work (with my previous ISP using a different router) just fine.


I can connect to VPN okay, but when I try to launch a virtual app (Windows 7) I get the usual pop-up asking if I want to run the app - I answer Yes but then.... well nothing happens.   It's the same in IE11, Chrome and Safari.  No error or warning messages, just nothing,


VPN works fine from other locations (just not home - which is where I need it!).


Have searched around and found other postings like this:-​44/c/346,402,405

(Tried that and it hasn't worked). 


Tried switching off parental controls - but that did not good either.


Also tried factory reset of the hub (not that I've changed any settings) with same result.


This old thread seems similar, but specifically states that the issue wouldn't affect HomeHub 5:



I'm working on a wired PC in home office, so wireless isn't an option.


Can anyone help?  It's like something is blocking the application but no messages etc.

0 Ratings
Message 2 of 3

Re: Company VPN not working with Home Hub 5

Do you connect via a website or via a client? If it's via a client then try adjusting the MTU on the network interface on the device that's connecting to the VPN try for example 1200. If that doesn't work I'd get your support guys to talk to the software vendor as I'd guess you aren't the first person to have this problem.
0 Ratings
Message 3 of 3

Re: Company VPN not working with Home Hub 5



I connect via a website - as I have always done.   Our support team say that no-one else has reported similar problems..  I can access from other site s(just not home)  so it's clearly something on the Home Hub or my home network..


Anyone else got any ideas?

0 Ratings