cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dougcoull
Contributor
530 Views
Message 1 of 4

DrayTek 2860 Loads only a few web sites

Anyone help with this please?

My DrayTek 2860 connects fine to BT Infinity - status lamp glows solid.

Strangely sites like Facebook and the Met Office load fine but vast majority of sites fail.

When I reconnect my TP router all goes well.

Feels it's a settings issue but I've set everything up as per DrayTek's instructions and double checked the screens.

Firewall switched off but problem persists.

Any help appreciated.

0 Ratings
Reply
3 REPLIES 3
RobbieBaron
Contributor
512 Views
Message 2 of 4

Re: DrayTek 2860 Loads only a few web sites

Try making the DNS settings of the DrayTek 2860 the same as the TP-Link router.

0 Ratings
Reply
dougcoull
Contributor
492 Views
Message 3 of 4

Re: DrayTek 2860 Loads only a few web sites

Thanks Robbie - router defaults to Google DNS (8.8.4.4 - 8.8.8.8) so I changed to the BT ones but it hasn't helped I'm afraid.

0 Ratings
Reply
dougcoull
Contributor
471 Views
Message 4 of 4

Re: DrayTek 2860 Loads only a few web sites

Well managed to get things sorted and back to normal.

Unsure of actual fix which is frustrating.

However for anyone else having issues this may help.

I carried out a firmware upgrade on the router and on reading the notes I saw this - "setting the WAN1 MTU value to 1492 or smaller will allow for normal Internet connectivity."

I had already changed this so not conclusive.

I've also left my DNS settings to Google ones having read this - "We recommend changing your DNS settings from their default settings (provided by your ISP) to those of the top Public DNS servers."

Hope this info is helpful and thanks for the reply Robbie - appreciated.




0 Ratings
Reply