cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
lazyllama
Aspiring Contributor
703 Views
Message 1 of 8

HH3A rebooting several times a day since firmware update on Monday.

Go to solution

My Home Hub 3 A (BT Infinity) got firmware 4.7.5.1.83.8.94.1.37 on Monday morning.

Since then it's rebooted several times each day. Some of those reboots show in the reboot log as being at exactly the same time of day (see matching colours below):

 

03:39:16, 21 Mar.( 20.370000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
00:47:24, 21 Mar.( 20.320000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
22:18:20, 20 Mar.( 20.310000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
18:18:18, 20 Mar.( 20.300000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
12:41:52, 20 Mar.( 20.270000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
08:57:02, 20 Mar.( 20.300000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
00:00:19, 01 Jan.( 20.130000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
07:04:43, 20 Mar.( 20.200000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
22:18:17, 19 Mar.( 20.180000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
18:44:33, 19 Mar.( 20.040000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
18:32:46, 19 Mar.( 19.980000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
18:18:17, 19 Mar.( 20.070000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
12:41:47, 19 Mar.( 20.060000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
08:41:48, 19 Mar.( 20.040000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
22:18:15, 18 Mar.( 19.960000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
18:18:14, 18 Mar.( 19.940000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
12:41:47, 18 Mar.( 19.540000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
08:41:48, 18 Mar.( 19.560000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)

 

The error log shows a bunch of WGET TLS errors and '1 BOOT, 4 VALUE CHANGE' messages around the reboot times.

 

22:21:36, 20 Mar.( 215.600000) CWMP: session closed due to error: WGET TLS error
22:21:21, 20 Mar.( 200.800000) CWMP: Server URL: https://pbthdm.bt.mo; Connecting as user: ACS username
22:21:21, 20 Mar.( 200.800000) CWMP: Session start now. Event code(s): '1 BOOT,4 VALUE CHANGE'
22:20:12, 20 Mar.( 132.210000) CWMP: session closed due to error: No response
22:20:05, 20 Mar.( 124.570000) CWMP: Server URL: https://pbthdm.bt.mo; Connecting as user: ACS username
22:20:05, 20 Mar.( 124.560000) CWMP: Session start now. Event code(s): '1 BOOT,4 VALUE CHANGE'

 

Now to me this looks like the HH is trying to get another firmware update several times a day and is failing and rebooting.

 

Anyone have any ideas? Should I try the factory reset, and if I do can I restore my backup config without problems?

 

(Note to self, when reporting a problem that causes your internet connection to go at 08:41 each morning, don't try it at 08:41 - it just went again).

0 Ratings
Reply
7 REPLIES 7
Moderator
Moderator
661 Views
Message 2 of 8

Re: HH3A rebooting several times a day since firmware update on Monday.

Go to solution

Hi lazyllama,

 

Thanks for posting. I'll take a look at this for you. Drop me an email with the details. You'll get the 'contact us' form in the about me section of my profile.

 

Cheers

 

David

 

Community ModeratorDaveM
Did you get the help you needed?
Help others by clicking on ‘Mark as accepted solution’
Show your appreciation!
Click on the star next to a reply to say thanks
Help guide to using the community? Click below
Kudos”Kudos”
0 Ratings
Reply
prinknash
Expert
652 Views
Message 3 of 8

Re: HH3A rebooting several times a day since firmware update on Monday.

Go to solution

lazyllama,

 

I'm far from expert and I'm sure the mod will be able to tell you more - but I think it would be useful to know what the System log says around the time of these reboots. (I've got a HH5 but I think the event logs for the HH3 are similar.)

 

The TR069/CWMP events you quote are, I think, just your hub telling the remote BT/Motive ACS server that the hub has rebooted, which is one of the things it's supposed to notify. What would be interesting would be to know what the System log says at the time. On the HH5 it might say "OpenRG will go down for reboot in 5 seconds", then "OpenRG is going for reboot by IPC command", then "The system is going DOWN for reboot". Do you see anything like that?  

 

I'm not sure the WGET TLS error means your hub is trying to download an update. I suspect it's just a breakdown in communications between your hub and the ACS. I get the same error on my HH5 sometimes and I'm on the latest firmware already. But the rtegularity of your rebots is very striking and can't just be coincidence!

 

p

 

 

 

0 Ratings
Reply
lazyllama
Aspiring Contributor
636 Views
Message 4 of 8

Re: HH3A rebooting several times a day since firmware update on Monday.

Go to solution

Thanks for the replies, I'll drop DavidM an email.

 

As for what the HH logs says before the reboot, pretty much nothing:

 

18:18:48, 23 Mar.( 43.530000) WAN Auto-sensing running.
18:18:30, 23 Mar.( 25.300000) WPA/WPA2 mode selected
18:18:30, 23 Mar.( 25.300000) WPS disabled
18:18:25, 23 Mar.( 20.550000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
17:50:32, 23 Mar.(15847.940000) Host Unknown-ec:a8:6b:f9:6c:bb (MAC ec:a8:6b:f9:6c:bb) using IP 192.168.1.41 detected on interface eth0, port -1

 

So nothing for about half an hour before the reboot (we went out so there was no human-driven usage).

 

I did a factory reset, followed by a reload of my saved config today at about 13:30 today, but at 18:18 this evening it went again.

 

 

0 Ratings
Reply
lazyllama
Aspiring Contributor
616 Views
Message 5 of 8

Re: HH3A rebooting several times a day since firmware update on Monday.

Go to solution

A bit of an update:

The last three reboots (05:21:20, 07:50:11 and 10:17:52 this morning) have all been preceded by:

PPP LCP Send Termination Request [User request]

.. about a minute or so before the reboot message. Different timings for the reboot - not matching the set pattern I was seeing previously.

 

I see there's at least one more thread related to that  PPP LCP Termination message including this 25 pager.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
614 Views
Message 6 of 8

Re: HH3A rebooting several times a day since firmware update on Monday.

Go to solution
0 Ratings
Reply
lazyllama
Aspiring Contributor
587 Views
Message 7 of 8

Re: HH3A rebooting several times a day since firmware update on Monday.

Go to solution

Well, the problem continues and has reverted to rebooting at set times of the day (plus occasional irregular times).

 

08:41:53, 25 Mar.( 20.580000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
22:18:27, 24 Mar.( 20.600000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
20:48:13, 24 Mar.( 20.560000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)
18:18:25, 24 Mar.( 20.570000) Booting firmware 4.7.5.1.83.8.94.1.37 (Type A)

 

The last few reboots haven't had the "PPP LCP Send Termination" occuring before the reboot, so it's not likely to be down to line conditions, unless something is happenning to the exact minute several times per day, and which just coincidentally didn't happen until the firmware upgrade.

 

As yet, there's been no response to the email sent but something might be going on that I'm not aware of.

 

0 Ratings
Reply
lazyllama
Aspiring Contributor
555 Views
Message 8 of 8

Re: HH3A rebooting several times a day since firmware update on Monday.

Go to solution

A final update on this. 

 

NeilO got in contact to help look at the problem and yesterday I replaced the HH 3A with a 3B. So far it's been absolutely fine.

I was on holiday for a week or so which is why there was a delay installing the replacement hub. During that time, the 3A hub was rebooting at the same times (even after the clocks went forward) 3 or 4 times per day.

 

Very pleased with the service and all is now well, touch wood 🙂

0 Ratings
Reply