cancel
Showing results for 
Search instead for 
Did you mean: 
gwaelod
Aspiring Contributor
638 Views
Message 1 of 11

HH4 - can't connect to it via ethernet or wireless

Go to solution

I'm struggling with intermittent fault - it happened on a HH3, but same problem is now beginning to repeat on a replacement HH4 I was sent.

 

When fault manifests itself (lets call it "faulty mode") I cannot connect wired or wirelessly to HH - I cannot raise the Homehub Admin page either via "bthomehub.home" or "192.168.1.254" and that is true for all It devices in the house (Win xp box, Win7 laptop and a rasp pi).  When this fault is apparent there is no internet access, and pure wifi devices (kindles and android phones) all are unable to access internet, and an ethernet connected youview box also loses connectivity to internet.

 

However - HH is obviously still working to an extent, because a both wireless and ethernet connected devices can all interact on the network, files on the NAS remain streamable and browsable by everything that needs to connect.

 

I have FON, and that still operates correctly when the HH is in "Faulty mode" - ie my wireless devices can all connect through it to the internet, and that FON connection is definitely coming from my HH not from a neighbours - if I power down the Hub I have no FON connections showing up in any of my devices.

 

HH has all the lights showing properly...when in faulty mode the devices I can browse to on the network have 169.type Ip addressess rather than 192. addresses.

 

Reseting the Hub and or powering it on and off sometimes makes the fault go away, but often it doesn't.  Factory reset sometimes cures it, but again often it doesn't.  System has sometimes gone into faulty mode whilst just working away sweetly, with no It equipment being powered up/down/connected/disconnected. I've tried tricks like clearing caches  used different browsers chrome/FF/IE but no avail.

 

I noticed this initially with a HH3 - that got gradually worse (more faulty mode incidents until it remained in faulty mode) BT sent me a HH4 about 1 month ago as a replacement, now the same symptoms are appearing on my HH4 (twice in 3 days)...so what's the problem, is it my settings/something I should be doing, or is it a duff HH4 as well.

0 Ratings
Reply
10 REPLIES 10
Distinguished Sage
Distinguished Sage
631 Views
Message 2 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

A few things to check, where is your Homehub positioned. Is there anything nearby that could be causing interference? Is there anything that could be causing it to over heat? Have you checked your cables from phone socket to homehub? Have you tried a new filter?

0 Ratings
Reply
gwaelod
Aspiring Contributor
626 Views
Message 3 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

Hi thanks

 

HH is away from direct heating and other electric stuff on a shelf away from the inevitable cluster of IT stuff where the main pc sits and it doesn't appear to get hot.

 

I don't think there is an interference issue..certainly not noticed any diffrenece when eg microwave/tv/smaller stuff etc is on or off

 

New filters fitted twice now - one an old "new" filter with previous HH and a brand new shiny one when this was installed.  Cable from socket is also fresh and new with new HH.  Being plugged into the half face test socket also makes no difference, and I have only a master socket in the house with no extension phone cables etc.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
621 Views
Message 4 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

When you do the factory reset of the homehub do you hold the pin into the recess button on the rear for about 20 seconds? If not, please try that and see how you get on.

0 Ratings
Reply
gwaelod
Aspiring Contributor
609 Views
Message 5 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

I think I normally hold it in for 6 0r 7 seconds.

 

However I have just reset it as you described by holding for 20 seconds.  when I did it my hub was operating normally, but after resetting for 20 seconds it went into Faulty Mode.  I reset again for 20 seconds and it remained in Faulty mode...which is where it is now, and I'm posting this via BT Fon, as it's now my only proper connection to Internet.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
602 Views
Message 6 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

Another couple of things to try.

 

You have said when it's in "Faulty Mode" you can't access the hub management pages. When that happens can you unplug from the phone line and try accessing the hub management pages to see if it lets you.

 

Can you try plugging the homehub into a different electrical socket and if possible not a double socket sharing anything.

 

Because this happens to all your devices it would rule out drivers etc on your devices and as you have changed cables that rules them out so it really only leaves a faulty homehub but it's strange how it has developed the same fault as your previous hub.

 

0 Ratings
Reply
580 Views
Message 7 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

I think a clue to what is happenning is the 169.xxx.xxx.xxx IP addresses.

 

These show a failure of the connecting device to obtain a valid DHCP IP address from the router, and the 169.... gets auto-assigned by the device itself. On a network, devices all with 169-type addresses can communicate with each other, as you've found out.

 

So the problem that needs fixing is with the DHCP server in the router, which is not serving valid IP addresses when requested.

 

Here are two things you can try, maybe do the first with your PC and the second with another device, see which works better for you:

- Assign a static IP to the device by setting it in Windows. Set it outside the router's DHCP range but with the same first three parts to the IP. eg 192.168.1.201. There's a guide here.

- In the HH DHCP admin pages, reserve a fixed IP for another of your devices, using its MAC address, again outside the DHCP range. While you're at it, set the lease renewal time to its maximum.

 

If those don't work, send the blooming thing back!

Highlighted
gwaelod
Aspiring Contributor
569 Views
Message 8 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

Hi tried unplugging from the phone socket and restarting - still can't get the hub admin pages that way either - and ip remains 169........  Am about to try from a different power socket

0 Ratings
Reply
gwaelod
Aspiring Contributor
568 Views
Message 9 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

I'm in the process of doing this now - will let you know, but it's taking me 10-15 reset cycles to get an Admin page up to get at the DCHP settings...once I get it up I'm then reluctant to cycle it off and on again to check!!

 

If that does work though what happens when I add a new device to the network....

0 Ratings
Reply
gwaelod
Aspiring Contributor
560 Views
Message 10 of 11

Re: HH4 - can't connect to it via ethernet or wireless

Go to solution

Ok - I think...tentatively...I've cracked this

 

I have a Freecom Network Drive on the network, it appears to be handing out DCHP to everything with defaults of 169.254.xxx.xxx - if it powers up before before the HH does.  A reset of the HH with this network drive still connected won't enable the HH to hand out it's own set of DCHP numbers.

 

I've now disabled the DCHP functionality in the Network drive...and it all seems to play nicely now.  The extended period of time with the new router all working was probably due to me powering everything off, deliberatelty brining up new HH first, and then sequentially adding other bits of kit to it....the Network drive would have been one of the last things I added...my network went pearshaped when I powered everything down when I went on holidays, and switched it all back on in a different order.

 

I think I'll go and dig out the old HH3 from the back of the garage and see if it works...if so I probably owe BT an apology.

0 Ratings
Reply